0

Please help as I have landed into a trouble with my flask server for pset8/mashup. Per the spec within mashup/ I execute pip install --user -r requirements.txt and then in a terminal window I execute export API_KEY=value (value from credentials in my console). I have made two API keys though I use one of them. Then in mashup/ I execute flask run and then in another terminal within mashup/ I execute phpliteadmin mashup.db. After this when I go to CS50 IDE>Web Server I get a webpage saying "no application seems to be running here". Flask was showing the following messges : * Serving Flask app "application" * Forcing debug mode on * Running on http://127.0.0.1:5000/ (Press CTRL+C to quit) * Restarting with stat * Debugger is active! * Debugger PIN: 270-621-200

"Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)" seems relevant as it is serving PORT 5000 which I guess should be 8080 for my application to run. But I am too naive to do this. So, plse tell me how to resolve this issue to get my CS50 IDE server run my application.

1

Change the call from flask run to flask run --host=0.0.0.0 --port=8080 and it should work, as per this reddit post.

4
  • Thanks, buddy, you are a true genius! I was almost clueless how my server would work but now this is resolved. In fact, I did notice that David used the above code to run flask in some of the applications of week8 and week9 lectures but didn't pay attention then. Anyway, thanks again. – sk.76 Aug 2 '17 at 11:19
  • I have the same error but my output says: * Running on ide50-chrisdziewa1.c9users.io:5000 I tried the above fix and it still isn't working. Any ideas? It was working fine yesterday. – razzdango Aug 2 '17 at 23:27
  • @razzdango According to the cs50 status page this was fixed with a new IDE version (update50). – DinoCoderSaurus Aug 3 '17 at 11:34
  • @razzdango do u execute update50 before running flask? – sk.76 Aug 3 '17 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .