I am trying to update my CS50 IDE. I know there is an update too because at the top pf my screen there is an orange bar saying

An update is available for CS50 IDE. Run update50 in a terminal window.

But, when I run update50 in the terminal window, I get this error message:

Update50 - Sat, 05 Aug 2017 08:41:51 +0000
You have an old workspace. See https://cs50.ly/disk for instructions on 
how to upgrade your workspace! Something went wrong! The output has been
logged  in /home/ubuntu/lib/ide50.log

I already went to the link and followed the instructions. (I saved my workspace to my computer's desktop, then deleted the workspace and am now in an almost empty one) I have no idea why I am still getting the same error message! Please help as I can not continue coding while this is not working. Thanks for any help!!

1 Answer 1


Update50 does not work in the current workspace because there is not enough space it is necessary to visit the page https://cs50.ly/disk to update the workspace, following the instructions, with 5 GB more

  • I did that, but I am still getting the same error. Any suggestions? Commented Aug 5, 2017 at 15:54
  • Works well for me, you have to delete the old workspace
    – MARS
    Commented Aug 5, 2017 at 19:14
  • I reloaded the cs50 ide page and got it to work! Thanks! Commented Aug 7, 2017 at 18:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .