I have restarted doing cs50 from 2017 after 3 months away. Upon loading up the IDE, it requested an update which I allowed it to do. I'm going through my old problem sets as a refresher, but when I try to perform check50 on for example my vigenere.c it comes up with:

~/workspace/Pset2/ $ check50 cs50/2017/x/vigenere

Traceback (most recent call last): File "/opt/pyenv/versions/3.6.0/bin/check50", line 6, in from pkg_resources import load_entry_point File "/usr/lib/python3/dist-packages/pkg_resources.py", line 1479, in register_loader_type(importlib_bootstrap.SourceFileLoader, DefaultProvider) AttributeError: module 'importlib._bootstrap' has no attribute 'SourceFileLoader'

The same happens with typing in to the command line

$ check50 cs50/2017/x/vigenere vigenere.c

Is this happening because there is a new course running? And would I have to enrol in that instead?


That can be solved by restarting the IDE. In the menu CS50 IDE > Restart

  • Thank you for responding. This worked in that it solved this problem. I then encountered an issue with check50 not being enabled for my account, which someone else also had and had posted on reddit. reddit.com/r/cs50/comments/6wk3ob/… The solution edit they gave at the bottom of their post worked for me too
    – Mnargh
    Sep 7 '17 at 11:43
  • @Mnargh glad to hear. Can you please accept my answer so this will be marked as solved. Thanks.
    – curiouskiwi
    Sep 8 '17 at 2:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .