Does anyone recently have problem with this url "http://download.finance.yahoo.com/d/quotes.csv?f=snl1&s={}" in helpers.py of pset7?

Before yesterday, the lookup() in helpers.py worked fine but since yesterday, it have started return None for every symbol, even FB or AAPL. I have tried the url: Does anyone recently have problem with this url http://download.finance.yahoo.com/d/quotes.csv?f=snl1&s=AAPL on my browser and it returned "Sorry, Unable to process request at this time -- error 999." I guess there is something wrong with Yahoo Finance but staff solution at http://finance.cs50.net/ is still working.


3 Answers 3


Thank Brenda Anderson from Facebook group CS50 for providing a new code for helpers.py

  • My thanks as well :)
    – Seph
    Nov 2, 2017 at 23:35
  • Thank you so much. Been stuck at this for so long because i thought nothing will ever go wrong with helpers
    – Iberico
    Dec 5, 2017 at 5:00
  • It still doesn't work for me even though I've changed the code. Someone help pls Mar 5, 2018 at 14:31

Yahoo finance has killed it's API

You can read more about the topic via the Hacker News discussion linked below.



Use https://iextrading.com/developer/docs/ instead of Yahoo Finance services.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .