0

I am having trouble opening phpliteadmin from the CS50 IDE. I keep getting the error message "ide50-devon-brown.cs50.io refused to connect."

I had similar problems with running flask directly from the CS50 IDE, but was able to get around it by replacing the address provided by the IDE (http://ide50-devon-brown.cs50.io:8080/) with http://ide50-devon-brown.cs50.io/

I have tried different browsers (edge, chrome, firefox) and altered security settings, but continue to get the same result. I have also gone through the "running" section of pset7 several times and have run update50 multiple times.

I would really appreciate your help! I am running into quite a few walls on pset7, not being able to see the tables I am creating.

Thanks!

3
  • Have you tried double-clicking finance.db to open it inside the IDE itself? – curiouskiwi Dec 7 '17 at 0:13
  • Yes, I get the same error code there too – DevonB Dec 8 '17 at 0:33
  • have you run update50 recently? – curiouskiwi Dec 8 '17 at 4:07
1

phpliteadmin by default runs on a different port, 8082. When you start phpliteadmin on the terminal like phpliteadmin finance.db, you should see the correct URL, including the session password.

3
  • Yes, I noticed that the ports were different. I was hoping someone might have another way for me to connect to that port or a way to change the port to 8080 so that I can at least view phpliteadmin (even if that means switching off between phpliteadmin and flask). I get the "ide50-username.cs50.io refused to connect." error message using the URL provided. – DevonB Dec 8 '17 at 0:37
  • Have you started phpliteadmin from the terminal and clicked that link it prints to the console? What does it say? – Blauelf Dec 8 '17 at 8:23
  • I face the same problem and I get an ERR_CONNECTION_TIMED_OUT in Chrome. Double-clicking on finance.db in the explorer directly also says "ide-username.cs50.io took too long to respond". – Ameya98 Aug 17 '18 at 3:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .