0

For some reason, when running update50 in my IDE, it exits abruptly with this error message:

After this operation, 0 B of additional disk space will be used.
Setting up udev (204-5ubuntu20.25) ...
* udev requires hotplug support, not started
...fail!
invoke-rc.d: initscript udev, action "restart" failed.
dpkg: error processing package udev (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
udev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Something went wrong! The output has been logged in /home/ubuntu/.cs50/logs/update50.log

I've tried updating multiple times, I've restarted and refreshed my workspace, and I've used "~/.cs50/bin/update50." I'm not sure where to go now. Can anyone help me resolve this issue?

  • Sounds like a question for @kareem – Cliff B Dec 24 '17 at 5:25
1

Try running the following command:

sudo nano /etc/init.d/udev

and add the following line under ### END INIT INFO:

exit 0

Then hit Ctrl + x, then y, then Enter. After that try update50 again. If it works this time, repeat the same steps above, but this time remove the line you added.

| improve this answer | |
  • Thanks a bunch, it worked! – Jason_V Dec 27 '17 at 0:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .