I'm having some issues with downloading the distribution code for Pset8 (mashup). I am getting everything except US.txt and readme.txt. I do get the other text file, requirements.txt. Is anyone else having this issue?

$ wget http://cdn.cs50.net/2017/fall/psets/8/mashup/mashup.zip $ unzip mashup.zip $ rm mashup.zip $ cd mashup $ ls application.py mashup.db static/ helpers.py requirements.txt templates/ $ wget http://cdn.cs50.net/2017/fall/psets/8/mashup/US.zip $ unzip US.zip $ rm US.zip $ ls application.py mashup.db requirements.txt templates/ helpers.py readme.txt static/ US.txt

This is the process, but I only receive:

application.py helpers.py mashup.db requirements.txt static/ templates/

  • I've also tried ...cdn.cs50.net/2018/fall.... in the url, but that did not help. I found a github account with the two documents I need, but I was not able to download or view US.txt because the file is too large. (?) Mar 21, 2018 at 23:39
  • Just want to get started on the problem set, so if anyone has any ideas, or would be willing to share the file(s) with me in some other way, I would be glad to hear it! Mar 22, 2018 at 1:08

1 Answer 1


You only show the instructions from the spec, not what happened when you ran the commands, so this answer is only speculative. First, I followed the directions and it worked as expected. Some possibilities

  • A copy/paste accident? Like mashup.zip downloaded twice instead of mashup.zip and US.zip
  • Wrong directory? US.zip is in another directory, like pset8 instead of pset8/mashup

You can download the US.txt file from Cs50.tv -> problem sets -> problem set 8 -> source code. You would then upload it to the IDE.

  • Thanks in advance! I will try this when I get home tonight and check if it works. Mar 22, 2018 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .