1

enter image description hereenter image description here its still showing me the same error.. make: *** No rule to make target `cash'. Stop.

1

Your files are in the wrong directories. They are in ~/workspace/, while cash.c should be in ~/workspace/pset1/cash/, where you tried to make an executable from it.

  • actually its there its just within the pset1 directory. – Asha Thomas Jun 5 '18 at 17:15
  • Your screenshot shows three files in ~/workspace/ which following the instructions should be placed in sub-directories of ~/workspace/pset1/ instead. make and check50 don't really care about the directory you use, but the .c files need to be in the current one when calling one of the commands, and the directory structure they suggest is very reasonable. – Blauelf Jun 5 '18 at 17:38
  • ok I will check on to it. Thank you. – Asha Thomas Jun 5 '18 at 17:44
  • still the same error. help me out – Asha Thomas Jun 6 '18 at 5:32
  • Have you tried putting the files into the right directories, e.g. mv ~/workspace/cash.c ~/workspace/pset1/cash/ or equivalent drag&drop in the file tree on the left? – Blauelf Jun 6 '18 at 6:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .