0

enter image description hereWhile compiling speller using make command the following shows up: /usr/bin/ld: cannot find -lstdbool /usr/bin/ld: cannot find -ldictionary /usr/bin/ld: cannot find -lctype /usr/bin/ld: cannot find -lstdio /usr/bin/ld: cannot find -lsys/resource /usr/bin/ld: cannot find -lsys/time /usr/bin/ld: cannot find -lstdlib /usr/bin/ld: cannot find -lstring clang: error: linker command failed with exit code 1 (use -v to see invocation) make: *** [speller] Error 1

Where does the bug lie?

7
  • can you post a screen shot of the IDE after running the make command please?
    – Cliff B
    Jun 9 '18 at 20:09
  • @CliffB I've uploaded the screenshot.
    – rajat008
    Jun 10 '18 at 9:46
  • @user11990 Have you tried turning it off and on again? Seriously: "CS50 IDE" -> "Restart workspace". Sometimes fixes problems after an update50 run.
    – Blauelf
    Jun 10 '18 at 15:52
  • Still the same.@Blauelf
    – rajat008
    Jun 10 '18 at 17:55
  • Did you modify the makefile?
    – curiouskiwi
    Jun 12 '18 at 4:20
0

Maybe you've tried to list the libraries you included in the Makefile under LIBS using the -l flag. There's no need to do that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .