0

~/workspace/pset4/recover/ $ make recover

clang -fsanitize=signed-integer-overflow -fsanitize=undefined -ggdb3 -O0 -std=c11 -Wall -Werror -Wextra -Wno-sign-compare -Wshadow recover.c -lc

clang: error: linker command failed with exit code 1 (use -v to see invocation)

2
  • That line is a bit short. Is that the full output? Is there a makefile you messed with? Also, have you tried restarting your workspace? – Blauelf Jun 15 '18 at 15:41
  • no, I guess I dnt mess with the makefile. Ya, I tried to restart my workspace a number of times but shows the same error. it also includes this line in the output: /usr/bin/ld: cannot open output file recover: Is a directory – Asha Thomas Jun 15 '18 at 15:59
0

The line you showed in the comment makes me assume you accidentally created another directory named recover within your ~/workspace/pset4/recover/ directory. As directories and files share the same namespace, the linker cannot create an executable with the same name.

Remove or rename the directory ~/workspace/pset4/recover/recover

3
  • yes i have two directories but if I end up deleting one the other directory also gets deleted ....what to do – Asha Thomas Jun 15 '18 at 16:12
  • For deleting files, use rm command on the terminal. I had malfunctions with deleting in the file tree (it somehow was repeating my remove command on another file), so I don't use that function any more. – Blauelf Jun 15 '18 at 16:38
  • thank you it worked!!!!!! – Asha Thomas Jun 15 '18 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .