0

This is a really basic question, but I can't "make notes" in pset 3 . I don't know what is wrong. Here is what I do:

I tried the following, but maybe it's wrong because "notes" is not a directory hence I cannot get "inside" it:

~/workspace/pset3/music/ $ cd ~workspace/pset3/music/notes/ bash: cd: ~workspace/pset3/music/notes/: No such file or directory

I also tried just :

~/workspace/pset3/music/ $ cd ~/workspace/pset3/music/ ~/workspace/pset3/music/ $ make notes

and I get several errors.

I also tried:

~/workspace/pset3/music/ $ make notes 5

thinking maybe i got errors (in the attempt mentioned prior to this one) because there was no command-line argument (which I thought I did here by entering 5 as the octave number), but even with this last attempt I got errors.

What am I doing wrong? If you see my mistake(s), please let me know.

Thank you! John

0

First, you don't have a "notes"directory. The notes.c file should be in the music directory.

Next, the command would be make notes while you're in the music directory.

If all else fails, make sure that you're in the music directory where all the source code files and just make to make all the executables at once.

Also, a review of the class material on "make" would be useful here.

If this answers your question, please click on the check mark to accept. Let's keep up on forum maintenance. ;-)

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .