0

I'm taking CS50's Introduction to Game Development and I don't know how to have the assignments working on Windows.

How does one run the assignments on Windows? I've tried downloading the lua binary as suggested on the page here: https://docs.cs50.net/games/2018/g/assignments/0/assignment0.html

Next I installed love2D as suggested on the same page (Avira reports a virus so you have to turn it off).

And now,...well, I don't really know how to run the thing. I've tried a few things, but just ended up sprinkling lua53.exe over my diskdrive a few times and stuff like that.

Can somebody please give a thorough, dumbed down explanation of what steps I should do so that I can properly run the assignments on CS50's Introduction to Game Development?

0

Just to verify: you downloaded the love-0.10.2-win{32|64}.exe and ran that to install version 10.2 of LOVE2D. (I only ask because downloading version 11 is a world of hurt viz. application0, and installing from the zip is way beyond my ken).

I found the easiest way to run the project is creating a shortcut, as described in the Getting Started wiki page.

You can also launch the game from the command line:

"C:\Program Files\LOVE\love.exe" "C:\games\mygame"
"C:\Program Files\LOVE\love.exe" "C:\games\packagedgame.love"

You can create a shortcut to do this; simply make a shortcut to love.exe, right-click on it and select "Properties", and then put the command line you want in the "Target" box for the shortcut.

where "C:\games\mygame" is the path of your "application0" directory.

2
  • Thanks. It kinda worked. The running worked, that is. Now I just have this other error which I don't know how to fix (appearently, the "push:setupScreen" method doesn't work).
    – bwna
    Aug 28 '18 at 20:29
  • OK, got it working eventually. If anybody is suffering the same problem as me (and I think there are people like this since GS50 has a broad audience and a lot of people still use Windows), you have to get the latest version of "push" from github and copy it into your directory. Then you have to go into the file and change the value for all the colours to be below 1. (the old 0-255 is now appearently 0-1).
    – bwna
    Aug 28 '18 at 20:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .