0

I saved a copy of the image of part of my caesar program to dropbox, and since then I've lost every directory except pset1. Can anyone tell me how to get it back, I;ve tried to reopen it with no luck, I tried to make a new one, but was told I couldn't make a directory that already exists.

I tried ls ~Dropbox/cs50/ -a and got cannot access ~Dropbox/cs50/ no such file or directory. All my files show on the device as they always were. The only one that works is pset1, I can still do 'hello world'. Although I can't make any changes in Hello.

The files exist, I can show the code on all of them on gedit, the terminal just doesn't recognize them. I tried mv .name.c name.c and got no such file or directory.

The files have no hidden indicators, they look like pset1 which does work.

When I run make pgm I get no rule to make target 'pgm'.

1
  • 1
    Try browsing your data through dropbox.com . If you're able to see all of them, then most likely the problem is with the software that's installed on your machine.
    – kzidane
    Oct 11 '14 at 19:26
1

The information you are giving is not very helpful to be honest. What do you mean you tried to reopen it? Is it there? What did you do before the files where lost? Before you start I would suggest that any machine that had ever used Dropbox with your account should be disconnected from the internet. The fact that it wont let you create a new one could infact be encouraging. I would suggest that you start by navigating to the dropbox folder that its content was lost using your terminal, and run the list command ls with the all flag -a.

eg.:

ls ~Dropbox/cs50/ -a

If the files are not listed here you most probably lost them. If they are listed with a preceding '.' in front they are so called hidden and that might be the reason you cant see them. You can rename them using

mv .name.c name.c

where name.c is your file name, so if they are images this could instead be myimage.jpg or whatever you chose. That would revile them.

Then just to keep all hopes alive try to login to your dropbox from your browser and check if your files exist. You can do that from here. If they do I suppose you can download them somewhere safe and sync your dropbox folder on your machine.

Then, if a machine that was previously synced with your dropbox account exists and if you are lucky enough and it did not synchronise yet with the delete instruction you might find your files there. However if you have such a machine remember to remove any connection to the internet before powering it :)

I hope this helps, if you give some more information about what exactly you did we might help a bit more.

Good luck!

PS: I know its really annoying to lose work so I would suggest instead of saving an image in dropbox as a copy of your work, create a dropbox directory and work directly in there. The files are very small so you shouldn't have space issues.

Edit: If that didn't work I just found out that dropbox keeps versions of its files so you could try to have a look at that as well here. Thanks to Margarita Papaefthimiou that happened to mentioned it in a conversation we had on data loss a few minutes ago. :)

Good luck again!

0

I think I know why you cannot access your file. When I do mv, the file is saved but the first letter of the file changes to a capital letter.

For example, I saved mario.c in a directory called HW. Now I mv ~/HW/mario ~/pset1. When I open the pset1 directory, the file name has become Mario (Case Conflict (1)).C. I cannot open the file by typing Mario.c or even by trying to type the whole name Mario (Case Conflict (1)).C. I don't know how to fix the issue with mv but you can get around it by renaming the file in Dropbox.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .