0

I am currently using a Windows Subsystem with Ubuntu 18.04 LTS, and I was trying to install check50 and submit50 following the instructions under https://cs50.readthedocs.io/.

However, when I attempt to run check50 --help, I get the error:

check50: command not found.

I get the same error for submit50, after following the instructions on the CS50 docs page. I have git installed already (version 2.17.1).

Can anyone help me with this? Please let me know if any more details/clarifications are needed.

0

Figured out why it wasn't working; I accidentally installed it on a specific user rather than root. Had to go back and re-install check50 and submit50 as a root user on my Linux sub-system; only then did it work.

2
  • Often you don't need to be root, but can also use sudo, assuming your user is allowed to use sudo. – Blauelf May 16 '19 at 10:08
  • @Blauelf I tried that too when j was attempting to install it through the user, but it gave me some errors. That gave me the intuition that something had gone wrong in the installation process. – BusyProgrammer May 16 '19 at 12:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .