0

I'm having problems with my trie dictionary.c file, if I try to run the whole program normally or through gdb, I'm getting no errors whatsoever and I'm getting the right answers.
Tho, when I try to run it through valgrind, it prints nothing and just writes "Killed". I'm thinking it is because of the load function but I can't get my head around it.
This is how my dictionary.c looks like, what am I doing wrong?

[Edit: code removed for Harvard Honor Code compliance.] '''

2
  • I tested your code in valgrind without any problems. Are you sure that you're running the correct version of the code? Otherwise, I suggest rerunning to see if it was a transient issue. IF this doesn't work, then it's time to engage one of the IDE specialists on the team.
    – Cliff B
    Aug 19 '19 at 21:09
  • I tested it and it worked out Yesterday it wasn't working ( I guess of the memory leaks that were still present in the ide thus producing performance issues? I only assume), tho, when I tried it right now, valgrind had no problem, strange. All in all, thank you for taking your time helping me out
    – Onion
    Aug 20 '19 at 6:52

You must log in to answer this question.

Browse other questions tagged .