I have done all of the following instructions for Pset2 readability but am still unable to execute "make readability":

"Execute cd to ensure that you’re in ~/ (i.e., your home directory)"

"Execute mkdir readability to make (i.e., create) a directory called readability in your home directory"

"Execute cd readability to change into (i.e., open) your new readability directory"

"Execute open readability.c to create and open in the editor an empty file called readability.c in your readability directory"

Whenever I type "make readability" I get "make: *** No rule to make target 'readability'. Stop.".

I tried help50, and it said "Do you actually have a file called readability.c in the current directory? If using a Makefile, are you sure you have a target called readability?"

3 Answers 3


I know you believe that you're doing everything exactly right, but I'm still betting you're not in the right directory.

From where you are trying to execute make readability, type in the command ls -al. This will list all the files and directories in your current directory. Is there actually a file called readability.c? If not, you'll get those errors.

The next question is this. After you created readability.c and entered your code in that file, did you save it and where did you save it?

If you still can't figure it out, run the ls command again and paste a screenshot of your IDE in the question.


The same is happening to me. I spent 3 hours trying to figure out what was wrong and still not sure. When I execute in Terminal open readability.c it opens a new tab in terminal, but not in the upper side where you code, and there is no file in directory under that name. Help!!!! Were you able to solve the problem?

  • Cliff B's answer sorted it out for me. I had to manually click "File", then "Save As", before saving it in the Readability directory.
    – LZR789
    Apr 17, 2020 at 10:45
  • Hey! I am having the same problem and I can not solve it. Can you help me? Apr 24, 2020 at 18:45
  • Have you manually saved readability.c in the readability directory?
    – LZR789
    Apr 25, 2020 at 19:22

I ma having the same problem I can not execute make readability. Any help out there? Thanks!

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .