0

I'm doing CS50 AI and as a result been using submit50 in VSCode via the Windows Subsystem for Linux. Until I updated my IDE to the April update, submit50 used to ask my GitHub username and password in the the terminal itself similar to CS50 IDE.

After the April Update, it redirected me to the GitHub website for authentication and ever since then, I've been getting an error and can't figure out how to fix this.

I've tried re-install VSCode and submit50, upgrading submit50 and none of this has helped.

The error I'm getting

I tried deleting Code from Appdata on uninstalling VSCode to remove all data and start with a fresh install hoping that I could re-login to GitHub in submit50 but that did not help as the account seems to have been saved somewhere else.

Git extension wants access to GitHub

Any help would be appreciated!

1

I noticed this a duplicate question that you have already posted here but I can't flag it as a duplicate, so I'll repost my answer here in case anyone chances upon this one instead:


This is due to the new automatic GitHub authentication introduced in VSCode version 1.45.

The temporary fix for this is to disable Git: GitHub Authentication in your VSCode settings either via the settings UI, or by adding the following line to your settings.json:

"git.githubAuthentication": false,

When you try to run submit50 again, a popup prompt for your username and password will appear instead!


Alternatively, you can disable Git: Terminal Authentication in your VSCode settings either via the settings UI, or by adding the following line to your settings.json:

"git.terminalAuthentication": false,

Via this method, you'll get the login prompt for submit50 inside the terminal as per usual.

  • Yeah this worked, thanks! – Suhas Thalanki May 11 '20 at 5:11
  • Can you please help with same error after disabling github authentication for vscode? – Shruti Katpara Jun 17 '20 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .