0

I am experiencing an error each time I call the lookup function within the buy route when the request method equals post. However, calling lookup during quote does not result in the same error. I restarted the program from scratch and redownloaded the zip file but still have the same error. I execute "export API_KEY= value" where value is the API key from the website. Can you shed some light, please?

ERROR: INFO:werkzeug:192.168.77.141 - - [12/May/2020 13:22:40] "GET /static/styles.css HTTP/1.0" 200 - DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): cloud-sse.iexapis.com:443 DEBUG:urllib3.connectionpool:https://cloud-sse.iexapis.com:443 "GET /stable/stock/aapl/quote?token=pk_ccf02df6120b435aa2836df2929b9bb6 HTTP/1.1" 200 None INFO:werkzeug:192.168.145.102 - - [12/May/2020 13:22:46] "POST /buy HTTP/1.0" 400 -

  • I don't think the problem is the API call, because the POST request to /buy gives a 400 (bad request) error.. Maybe a problem in buy.html? – DinoCoderSaurus May 13 at 16:13
  • Did you find any solution? I have the same problem – Mikpix Oct 29 at 19:50

You must log in to answer this question.

Browse other questions tagged .