I'm trying to upload my assignment, but I keep getting the same error whenever I run the check50 or submit50 command:

"Make sure your username and/or password are valid and submit50 is enabled for your account. To enable submit50, please go to https://submit.cs50.io in your web browser and try again. If you're using GitHub two-factor authentication, you'll need to create and use a personal access token with the "repo" scope instead of your password. See https://cs50.ly/github-2fa for more information!"

I checked my account details multiple times and they're the same as my Github ones so they should work, and I did authorize cs50 again recently (I had both check50 and submit50 from 2019). I don't know what to do, any help would be appreciated!!

6 Answers 6


Had similar problem with similar message. This is how we found out what was wrong:

  1. Executed check50 -h to see what logging options there were. Discovered we can turn on debug logging using --log-level option.

  2. Executed check50 --log-level debug path/to/folder.... In the output noticed: fatal: repository 'https://github.com/me50/USERNAME' not found.

  3. Navigated to the repository URL in the browser: https://github.com/me50/USERNAME

  4. Had to click "Accept Invitation" from bot50.

  5. Executed check50 path/to/folder/... and it worked fine using username and GitHub personal access token (instead of password).

  • 1
    Thanks. Solved the problem for me. Step 3 and Step 4 did the trick for me.
    – user32723
    Commented Jun 18, 2021 at 6:03
  • 1
    Step 3 and Step 4 did the deal for me as well. Thanks a ton! Commented Sep 7, 2021 at 12:05
  • 1
    yup, this did the trick for me as well. nice work! Commented Sep 18, 2021 at 12:45
  • After step 3 I have 404. But I don't have step 4, where find invitation from bot50? Commented Nov 20, 2021 at 1:11
  • Thanks. Solved my issue Commented Feb 24, 2022 at 8:41

Sign out of the ide with this link: http://ide.cs50.io and close the tab/window.

Next, sign completely out of github.

Next, open a new tab/window and go to http://ide.cs50.io You should be prompted to sign in. Do so.

Now try check50 again.

If you still get that error, send an email to [email protected] with your problem & details.


I had the same issue. I use brave as my browser and by default it has ad blockers which also block some scripts and other stuff. By turning the "shields" off, that solved my issue.


Just follow the instructions here https://docs.github.com/en/github/authenticating-to-github/creating-a-personal-access-token. This will allow you to access your Github repo using the command line. Once you have generated your token, just use it instead of your Github password when using check50 and submit50.


I made the mistake of not selecting any scopes when creating my personal token, maybe you did too? Just follow these instructions: https://cs50.readthedocs.io/github/#personal-access-token.

Hope this helps


I had to log out via the command "check50 --logout". Afterwards I was able to check and submit again...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .