0

Here I tried from brackets IDE live preview it was working completely fine, but now it doesn't, i think i maybe deleted sth from C parition that causes this, i'm searching hard but i don't know what to do,i did This is HTML Code and by the way i'm sure of the path because it works completely fine when i open it with chrome.

<!DOCTYPE html>
<html>
<head>
    <title>My Wallet</title>
    <link rel="stylesheet" href="../css/index.css">
    <link rel="stylesheet" href="../css/login.css">
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css">
</head>
<body>
    <header>
        <div class="title">
            <i class="fa fa-briefcase" aria-hidden="true"></i>
            <h2>My Wallet</h2>
        </div>
        <nav>
            <li><a href="index.html">Home</a></li>
            <li><a href="#about">About Us</a></li>
            <li><a href="#contact">Contact Us</a></li>
            <li><a href="login.html">Login</a></li>
        </nav>
    </header>
    
    <section class="container">
        <div class="login-img"></div>
        <div class="layer">
            <h2 class="form-title">Login Form</h2>
            <form method= "post">
                <label>Username:</label>
                <div class="input-group">
                    <i class="fa fa-user-circle-o" aria-hidden="true"></i>
                    <input type="text" placeholder="Enter Username">
                </div>
                
                <label>Password:</label>
                <div class="input-group">
                    <i class="fa fa-lock" aria-hidden="true"></i>
                    <input type="password" placeholder="Enter Password">
                </div>
                <input type="submit" value="Login">
            </form>
            <p>Don't have an account yet?<a href="Registeration.html">  Sign up now</a></p>
        </div>
    </section>
    <footer>
        All rights reserved by @Mazen Ashraf
    </footer>
</body>
</html>

This is what it should be like in webserver or file

11
  • I Used CS50 IDE too, and it doesn't work fine. and there isn't much time left can someone help me please – Mazen Dec 21 '20 at 13:05
  • Check the browser console for errors. The one that "doesn't work" seems to be missing the CSS. And it would indicate a pathing problem. – DinoCoderSaurus Dec 21 '20 at 14:40
  • INFO: * Restarting with stat INFO: 192.168.233.129 - - [21/Dec/2020 14:36:16] "GET / HTTP/1.0" 200 - INFO: 192.168.233.129 - - [21/Dec/2020 14:36:17] "GET /path/to/font-awesome/css/font-awesome.min.css HTTP/1.0" 404 - INFO: 192.168.83.137 - - [21/Dec/2020 14:36:17] "GET /css/index.css HTTP/1.0" 404 - ,this is the console. the same code was working completely fine 2 days ago without any modifications of the path, it just now says it couldn't load in webserver, but localy works completely fine – Mazen Dec 21 '20 at 14:58
  • I had a folder called css contains login.css, and another folder called templates contains login.html so i go back with ../ and then go to css file and acces login.css and that worked completely fine i don't know what happened – Mazen Dec 21 '20 at 15:01
  • Doesn't css have to be in static directory? What is calling "/path/to/find-awesome/....". That's not a real path. Check the browser console too. – DinoCoderSaurus Dec 21 '20 at 15:24
0

Css Files, Images, Fonts or anything you wanna link to your html page you should put in folder static, when you deal with flask and copy the right path of the file you want.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .