0

since you guys are my life line I think I'm allowed to ask dumb questions. I'm getting "no rule to make target 'list'", in my terminal. I know I've seen this before but I cant remember how to fix it and going through the motions from scratch repeatedly doesn't seem to work. thank you in advance Mr. Pratt since you'll more than likely help me like you always do, but I will, of course, take help where I can get it.enter image description here ps. I know I didn't capitalize and then not capitalize anything. I checked all that even if I spelled something wrong its spelled the same way every time. Been there with that mistake. enter image description hereenter image description here this is what happens when i run ls -a like Robert said to. the file isnt where i want it to be but the move command wont work(or i cant make it work. i know its me)

6
  • Can you edit the question to add the terminal command and it's subsequent error? Not seeing the actual terminal means that we can make a guess about what the issue probably is, but it'd be much more beneficial to give you a confident, exact answer. – Robert S. Pratt Mar 1 at 19:58
  • hold on im having issues giving you the screen shot – Aamon Van Mar 1 at 20:12
  • ok i modified my question to have that screen shot for you. for some reason i couldnt send it in the comments even though ive done that with you before. maybe its just my brain today – Aamon Van Mar 1 at 20:22
  • hey you know what? i think i figured it out. im using "make" to complile and i dont have cs50 in my header files. – Aamon Van Mar 1 at 20:42
  • nope wasnt . i lied – Aamon Van Mar 1 at 20:43
1

You are in your home directory ~/ and that is not where list.c is located. It looks like list.c is located in ~/classwork. Whenever you get an issue like this, try running ls -a (-a flag adds hidden files to the output in case the file you need is marked as such) to make sure that the file is in the directory you are in.

And you can just call me Robert, no need to be formal here. ;)

Let me know if you still have issues.

4
  • yes still have issues unfortunately i can see why though now. added a screen shot to my original question to show you what ls -a shows – Aamon Van Mar 1 at 23:45
  • You are still performing all of your commands in your home ~/ directory. Your ls -a showed that the files you are trying to move are not in the directory you are in. hello.c is in your ~/pset1 directory according to the tree beside the IDE. You need either need to cd into the directory where your files are located or type the full path to the file (like mv ~/pset1/hello.c ~/pset1/hello/hello.c) before you can use them in a command. – Robert S. Pratt Mar 1 at 23:56
  • i think i figured out why it keeps telling me when i clicked out of this file and into a new one and back it tells me that the code had been deleted and is "no longer available" why i can still see it and open it i don't know but i rewrote it as #include <stdio.h> #include <cs50.h> int main(void); printf("hello, world") and clanged it and it worked just fine – Aamon Van Mar 2 at 0:08
  • now comes the fun part with the turning in. this worked thank you so much. i am very patient and i got frustrated for a minute – Aamon Van Mar 2 at 0:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .