1

I'm confused because I did this successfully at first, then my appliance crashed and I had to start over, and now I am having trouble with the Makefile for copy.c

I have a file names "Makefile" that I made in gedit. It has the following code

copy: copy.c

clang -ggdb -std=c99 -Wall -Werror copy.c -o copy

I am getting an error that says "Missing separator. Stop"

I know that the indentation is necessary (which I have). I am wondering what else might be the matter?

1

The Makefile makes use of tabs for indentation.
Gedit automatically converts tabs to spaces unless specifically told to.

Open Gedit, choose from menu Edit->Preferences, click on the Editor tab from the windows that appears, and uncheck "Insert spaces instead of tabs".

Then reopen your Makefile, clear the spaces and insert tabs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .