0

(NOTE: I am using a Windows 10 laptop for the course, and I use the CS50 IDE to write my code.)

I really, REALLY do not understand how to run the lua code on the cs50 ide.

I tried "lua main.lua". It didn't work. It showed this: "lua: ./lib/push.lua:8: attempt to index a nil value (global 'love')" along with a traceback.

I tried "love ." and "love .." like Mr. Ogden did in the lecture. It did not recognize "love" as a command ("bash: love: command not found"). I've downloaded the framework and followed the instructions from the love2d site, and nothing helped. I just don't understand.

I feel really frustrated and I can't think straight. It feels like I'm missing something and I should know what it is but I can't figure it out for the life of me. Could anyone please help?

1 Answer 1

0

I am 99% sure that the Ubuntu environment where the CS50 IDE runs does not have Love installed and that we cannot install it there. This would be why the course talks about downloading Love to your own system and using Visual Studio Code to write your code. You can upload your project folders to the CS50 IDE for submission or push/submit them directly from your computer.

Hope that helps. If it does, feel free to click the check mark next to my answer. But if not, let me know and I'll try to help further.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .