1

I enrolled in the first version of the course and was able to navigate to the folders and psets without much issue. I let someone edit folders and settings in my virtual machine and now I think I've lost access to necessary directories for accessing source code.

Whenever I attempt to run the command cp -r ~cs50..etc (listed on this page), I get the error:

cannot stat '/home/cs50/pub/lectures..': No such file or directory

How do I fix this problem?

3
  • 1
    I'm not quite sure that appliance version 2.1 is still supported. That was 4 years ago so there might not be anyone here who can help you.
    – curiouskiwi
    Oct 30 '14 at 9:10
  • I made sure that I have the most up-to-date version of the appliance and tried to use the instructions at this url manual.cs50.net/2012/fall, and I get the same error message.
    – Ken Brown
    Nov 3 '14 at 0:13
  • Hi, can you paste the whole command you are trying to run? for what I understand by the error the folder you are trying to copy from/to doesn't exist. You may want to run the ls commando on the folder your want to copy or navigate to it using cd just to be sure that the folder is actually there. Nov 4 '14 at 10:37
1

Download a new, clean copy of the latest virtual appliance image and re-load your virtual machine following the steps from the CS50x 2014 course.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .