I am using windows 7 with chrome. When I type in the URL with:

http://w.x.y.z/pset8/ (with the real IP address)

I got the page unloaded with message: This webpage is not available.

I am sure all the steps for chmod are all correct and no missing. Anyone had the same problem and then how to solve it?

  • A note that I also tried on ipad and got the same result.
    – Cuie Wu
    Nov 10 '14 at 22:37
  • No problem on the internet connection and proxy settings.
    – Cuie Wu
    Nov 10 '14 at 22:38
  • Dose anyone has the same problem? I am still stucked.
    – Cuie Wu
    Nov 14 '14 at 22:30

I had the same problem and for me the solution was configuring the VMnet network adapters to use DHCP. I did it as follows:

  1. Click on the Start Menu search (bottom left corner)

  2. Type: "view network connections" find it on the list that appears and open it.

  3. Right click on "VMware Network Adapter VMnet1" and click on Properties. (You should be on the Networking tab in the new window that appears)

  4. Where it says "The connection uses the following items:" left click on Internet Protocol Version 4 and then left click on the Properties button

  5. In the new window you should be on the General tab. Click on the options that say: "Obtain an IP address Automatically" and "Obtain DNS server address automatically".

  6. Now click on OK then Close. You should still have your Network Connections window up.

  7. Repeat steps 3 to 6 but for "VMware Network Adapter VMnet8".

All done! Now make sure you restart your computer before opening the CS50 Appliance again. Hope this helps!

  • Thank you so much Jack for your magic. You FINALLY saved me!!!
    – Cuie Wu
    Dec 2 '14 at 19:27
  • NP, Glad it worked for you too! Good Luck with the rest of your course. I've still got to do pset8 and the final project :E Dec 10 '14 at 19:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .