2

Happy New Year!

I just downloaded the new cs50 Appliance and installed it using VirtualBox as I did the year before, which worked smoothly. I started Cs50 a few weeks ago, but wasn't able to finish it before the year ended. I am working on my Macbook.

Now I have the following problem: I can't adjust the window accordingly. I tried to change the display size through the settings (settings manager) but I am not able to choose anything than 600 x 480 or rather I can't choose anything at all.

Does anyone know how to solve the problem?

I found the suggestion to install the guest addition to VirtualBox, but to be honest, I didn't understand how to do it.

Thanks in advance!

1

You can install guest additions with the following command in the guest's terminal:

sudo apt-get install virtualbox-guest-dkms

See answer here and comments here.

Then restart the appliance. It should automatically choose the highest possible resolution of your screen.

| improve this answer | |
0

Adapted from: http://classroom.synonym.com/increase-size-virtualbox-mac-os-x-19016.html

Adjusting Screen Resolution

Step 1 Search for "com.apple.Boot.plist," one of the configuration files for VirtualBox. It resides in your VirtualBox folders, but depending on the version of VirtualBox you have installed, it may be in the Extra or SystemConfiguration subfolder.

Step 2 Make a backup copy of this file by copying and pasting it somewhere else.

Step 3 Open the original file with a text editor.

Step 4 Search within the file for "Graphics Mode," which should be in XML tags. Underneath the tag containing the element "Graphics Mode" there's a String tag containing the element "1280x1024x32" or something fairly similar. That string contains the pixels and color depths that VirtualBox uses for your display. Change that to whatever resolution your OS X machine supports.

Step 5 Save the file. Make sure to uncheck the check box that says "save with a .txt extension" to save it with the .plist file extension.

Step 6 Start VirtualBox; it now uses the new screen resolution.

| improve this answer | |
  • Thanks a lot! But I am not sure if that would solve the problem. The problem seems to be located in the Cs50 Appliance rather than in VM itself. There are no problems with the display using the older appliance (19). Any other idea? Or should I try it anyway? – Kubiti Jan 2 '15 at 16:17
  • See this post: cs50.stackexchange.com/questions/1060/… – Christopher Clarke Jan 2 '15 at 18:11
0

When the appliance is started, go to Devices>>Insert Guest Additions CD Image...

Click on VBOXADDITIONS_4.3.XX_XXXXX. The window should have a banner that says "Contains software". Hit "Run software", and type "crimson" as the password. When it is finished installing guest addititons, reboot the VM. Your screen resolution should be adjusted automatically.

| improve this answer | |
0

go to menu > display settings in the appliance itself, and select the right screen resolution

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .