I have already set the network's adopter to NAT. But still cannot connect to the internet. However, I can update the appliance using update50.

Would you advise?


3 Answers 3


do: sudo nano /etc/network/interfaces

add these lines at the end: auto eth1 iface eth1 inet dhcp auto eth2 iface eth2 inet dhcp

Make sure your adapter 0 is 'NAT', adapter 1 is 'host-only', adapter 2 is 'bridged'

  • Thank you @ Aditya Kashyap....Glenn, the system admin, has helped me sort out the problem by using the old hypervisor with 2014 CS50 virtual machine.
    – Hang Man
    Commented Jan 7, 2015 at 1:13
  • this solution works for me, but after changing the interfaces file, i needed to restart the appliance to apply the changes, else eth 1 and eth 2 aren´t recognized. thx!
    – SebBr
    Commented Jan 14, 2015 at 16:14
  • Could you elaborate on: Make sure your adapter 0 is 'NAT', adapter 1 is 'host-only', adapter 2 is 'bridged' How can I verify?
    – user4795
    Commented Jan 22, 2015 at 20:08
  • The above by Aditya seems to have worked for me. I now show an IP address. A few comments: "sudo" is a Linux override command. "nano" is a Linux text editor - a little tricky to use - but if you think you have done your edit correctly and the file looks good with the added lines - then Control-X will let you exit and then you choose to save it with your changes. As for the question by user4795, those 3 adapter settings appear in the "Devices" for the appliance that you see listed once you shut down the appliance.
    – user4941
    Commented Feb 1, 2015 at 7:03

Wow! i just reset the virtual network settings to default, and Woalaa!!! it worked.

Try this. go to "edit > virtual network editor > change settings > restore defaults"

  • I tried just about everything, and this is the only way that worked. When in doubt, try this!
    – user7277
    Commented Jun 1, 2015 at 21:26
  • Indeed, when you already did "sudo nano /etc/network/interfaces" and eth1 and eth2 were already listed in there, try restoring your default network setting. It worked for me and might work for you as well!
    – user7885
    Commented Jul 25, 2015 at 22:31
  • Thank you Ayobami!!! Commented Aug 6, 2015 at 22:03
  • This worked for me as well. Thanks Ayobami.
    – user9513
    Commented Sep 9, 2015 at 6:05
  • @Ayobami THANK YOU SO MUCH!!! I got tired trying all these different things. Only this worked out for me.
    – user10356
    Commented Dec 4, 2015 at 16:36

Try this in a terminal window:

sudo service network restart

If password is asked, use Crimson

  • I tried the above command and "NO DHCPOFFERS received" results. I have asked system admin of edx to give me a licence for VMWare Workstation for 32bit Window. Thanks
    – Hang Man
    Commented Jan 4, 2015 at 2:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .