13

I'm using Cs50 appliance 2014. I get missing network adapter message in bottom right side.

"ifconfig" gives the following output. ifconfig output

"sudo service network restart" gives the following output sudo service network restart gives this output)

I have 3 network adapters in VMware. 1. Bridge Connection 2. NAT 3. Host-Only

Any help is appreciated. Thank you!

  • this was the problem I had after installing iso on virtalbox, could not figure out how to fix, eventually I had to install vmware workstation and imported the appliance there, there it is working fine. – segmentationfaulter Jan 4 '15 at 17:52
  • I'm using Vmware Workstation 10. – Ibrahim Jan 5 '15 at 17:05
  • I had this issue, ended up installing the tools on my own Linux Mint 17.1 KDE partition. – pythonhax Jan 13 '15 at 23:10
  • same problem here anybody got link to manual pages for troubleshooting this problem thanks – Chris Tine Jan 27 '15 at 9:39
  • For solution see: cs50.stackexchange.com/questions/6166/problems-running-update50/… – user3115 Jan 31 '15 at 11:20
23

I had the same issue (installed from ISO on Hyper-V). I found that ip50 only checks for an address on eth1. Personally I only had eth0 active. I just updated the ip50 script to check eth0 instead and the IP address shows up fine now. Internet and appliance updates were working fine before and after.

To update the ip50 script, open a terminal window and run

sudo nano /usr/bin/ip50

Look for the line that reads:

declare inet=$(ip -f inet addr show eth1 2> /dev/null | grep inet)

and change it to read

declare inet=$(ip -f inet addr show eth0 2> /dev/null | grep inet)

Then CTRL+O to save the file and CTRL+X to exit. The change should almost immediately reflect by updating your IP address in the bottom corner.

| improve this answer | |
  • Man, you're the best! Finally someone solved the problem!! Thank you very much. – Ibrahim Feb 16 '15 at 14:06
  • is fine but, is miss after run update50 – Daniel N. Feb 21 '15 at 22:55
  • Just to add that this fix works running on bare metal too – user7921 Jul 28 '15 at 13:46
  • worked for me instantly – Joy Ahmed Sep 1 '15 at 11:50
  • You are the best! – priya Dec 9 '15 at 4:45
8

A fix for this on your end would be to add the additional networks in the VBox settings for the VM; network adaptor 2 should be Host-Only; (if nothing shows up in Adapter 2's name go to File > Preferences > Network > Host only, and click the top image-button on the right "Add host only network") and network adaptor 3 should be set to Bridged (you can leave out network adaptor 3 if you don't want to connect to the appliance from other machines inside your house).

run

sudo nano /etc/network/interfaces

and copy/type in the following lines:

auto eth1

iface eth1 inet dhcp

auto eth2

iface eth2 inet dhcp

‪You‬ can leave the last 2 lines out if you don't want the 3rd adapter.

Save the file and either reboot the appliance or run: sudo ifup eth{1,2}

| improve this answer | |
  • I got this on the last command. "Ignoring unknown interface eth1=eth1. Ignoring unknown interface eth2=eth." Btw I had disabled the "Vmware host-only adapter" in host OS. But I have it enabled now and still appliance doesn't detect it – Ibrahim Jan 5 '15 at 17:16
  • worked for me, but i needed to restart the appliance, ifup didn't recognize eth 1+2, thanks!! – SebBr Jan 14 '15 at 16:06
  • The way you do it is, after adding those lines to the interfaces file, you save the file by pressing Ctrl+O, and then confirm using Enter key – Ice32 Jan 17 '15 at 21:53
  • So should we "add" those lines at the end of the existing lines in the interface file, or should we delete whatever is there and replace with the four (or two) lines posted above? In my case, the existing lines are "auto lo", "iface lo inet loopback", "auto eth0", "iface eth0 inet dhcp" (four lines). By the way, running sudo ifup eth{1} gave me the message "Ignoring unknown interface", but sudo ifup eth1 gave me "eth1 is already configured". Thank you – user4799 Jan 24 '15 at 7:17
  • @fumikos You should add them at the end of the file and not replace what's in there, – Oussama Jan 24 '15 at 12:43
1

In addition to Cygni_61's comments, make sure to also a) have the actual virtual network adapter enabled on your computer: http://s18.postimg.org/ra1utxw8p/image.png b) have it actually "connected" in VMWare settings: http://s18.postimg.org/uiaxkq7w9/image.png

| improve this answer | |
0

I had the same issue. My only solution after much troubleshooting was to uninstall the appliance and reinstall. Reboot and my IP is back to normal. I know this sounds like a mess, but it took less than 30 minutes, where i've spent hours troubleshooting. Good luck.

-John

| improve this answer | |
  • Welcome to the CS50 StackExchange community! Could you please provide more detail as to what you mean by "uninstall the appliance"? Do you mean reinstalling the VM player? Or re-importing the .ova file? – abelinux Jan 5 '15 at 19:34
  • I uninstalled and reinstalled Virtual Box and the appliance with no luck. Also getting "Ignoring unknown interface eth1=eth1. Ignoring unknown interface eth2=eth." when I try the above. – user4615 Jan 11 '15 at 19:07
0

In addition to user3399551 comment: virtual network adapter not only must be enabled but also bridged to real internet connection. In Control Panel/Network and Internet/Network connections you should select virtual network adapter and real internet connection, click right mouse button and select "Bridge connections". It works immediately for me.bridge connections menu

| improve this answer | |
0

If you find you have an IP adress after doing this, but no internet connection, try going to: "edit > virtual network editor > change settings > restore defaults"

From in vmware itself under 'edit', and do the above for each of the three network adapters one after the other.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .