9

I've just installed the new 2014 CS50 Appliance (v.2014-24) inside VMware Workstation 11 according to the instructions. And its working fine, with the following exception:

If I run in terminal update50 command (as suggested at the start of every pset), the following happens:

  1. The update routine executes
  2. Update completes successfully
  3. "Settings Manager" item is no longer available in the "50 Menu"

I tried to perform Restart to the system, but "Settings Manager" never comes back, so I ended up recreating the whole appliance from scratch in VMware, and this time staying away from updating it (and so far, v.2014-24 is the latest one as far as i know).

But it is important to keep thing up to date, so I want to bring this issue with updating to someones (CS50's ??) attention, so it may be fixed with the future updates.

Also, if anyone else ever ran into this issue, and have some temporary "fix" or workaround, i'll be glad to hear about it.

13

After too much of a digging, I've finally found a fix to restore "Settings Manager" item to the "50 Menu":

Run in terminal:

gedit /home/jharvard/.config/menus/xfce-applications.menu

Then, find the following part:

<Include>
    <Category>X-Xfce-Toplevel</Category>        
</Include>

Add "Settings" category there, so it will look like this:

<Include>
    <Category>X-Xfce-Toplevel</Category>
    <Category>Settings</Category>       
</Include>

Save the file, and close the editor. Now "Settings Manager" item should be back in the "50 Menu". You may try to reboot the appliance, if it doesn't take effect immediately for you.

6
  • 1
    Worked brilliantly. I too had delayed updating but now I've done so and I still have my settings manager. :) be sure to 'accept' your own answer. – curiouskiwi Jan 6 '15 at 2:18
  • Thanks, I will do so once the 2-day timeout on accepting self-answers expires. – smartxed Jan 6 '15 at 11:16
  • 1
    Thanks! Easy and a permanent fix. – yohnnyjoe Jan 6 '15 at 13:54
  • would you expand on, "Then, find the following part: "? thanks! – mazal Jan 7 '15 at 22:53
  • Inside the 'xfce-applications.menu' file, find the '<Include>' section, and add there '<Category>Settings</Category>' line, just as I explained above. – smartxed Jan 7 '15 at 23:19
3

The fix will be added to xfce-applications.menu today, so hopefully subsequent update50s will not remove it again. Thanks for figuring it out!

1
  • Working on CS50 is actually challanging my "figuring things out" skills every week, and bringing it to higher levels :-) . And thanks for paying attention to bugs posted here! – smartxed Jan 7 '15 at 23:25
2

in terminal type

xfce4-settings-manager

this will bring up the GUI Settings Manager.

3
  • Thanks, that does opens up the Settings Manager, but how can i bring it back to the main Menu? I've noticed that in "Application Menu" properties, it specifies "use custom Menu File", but the file chosen is "None", may that be of any clue? Where this menu file should be located? – smartxed Jan 5 '15 at 13:21
  • 1
    I'm not sure. I've been using this as a temporary fix. – yohnnyjoe Jan 5 '15 at 14:29
  • Thanks, so I assume i'm not the only one facing this issue. – smartxed Jan 5 '15 at 15:07
2

My appliance is still upgrading, so I can't help with the changed Application Menu, but you can use the following workaround:

Create a empty file on your dekstop.

Add the following lines:

echo "CS50 Fix: Starting Settings Manager"
xfce4-settings-manager
echo "CS50 Fix: Settings Manager started.."

Save the file as "SettingsManager.sh".

Right click on it --> Properties --> Permission:

Check the box: "Allow this file to run as a program"

Now you can just click on this whenever you want to access the SettingsManager.

2
  • Thanks! While trying your workaround (which works :-) ), I've found that you can create a launcer shortcut: rightclick on desktop > "Create Launcher", and then type "Settings Manager", autocomplete will offer to create a launcher for Settings Manager, selecting it will create a proper shortcut. – smartxed Jan 5 '15 at 18:03
  • 1
    If you found the answer to your question, it'd be great if you could post it (as an answer) and accept it. – abelinux Jan 5 '15 at 19:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .