1

So... fresh instance of the cs50 2014 appliance (i.e. Ubuntu 14.04 LTS guest VM), running on Ubuntu 14.04 host OS, using VirtualBox. I've ran plenty of VMs on this machine before, so I'm pretty sure its not a matter of the hardware or other on the local machine.

The only thing I did prior to running update50 was install the VirtualBox guest additions so that I had something more than a tiny window to work with. Rebooted the VM and opened up a new terminal to run update50 from.

It's been running really slow - as in over two hours and its still stuck at 'Upgrading packages...'. Finally opted to kill it. Regular Ctrl+c didn't work, had to look up the process id using ps aux | grep update50 and kill it that way.

I've looked at various threads/posts, both here and on https://www.reddit.com/r/cs50/ ... not finding anything that quite seems to fit.

The network connection does work. I can ping google.com, I can ping reddit.com, and I can ping mirror.cs50.net.

I only have one working network connection - eth0 - which is using adapter #1 in VirtualBox. Nothing seems to be setup on adapter #2 / eth1. I have the warning 'missing network adapter' in lieu of the host-only network ip address i.e. 192.168.56.xxx. So it seems like ip50 isn't working either.

I'd like to get this stuff sorted out before I find that I can't run check50 when I need it down the road.

  • I also have the same exact issues. Though for the record, I'm up to pset4 without updating (from last year, I'm not that fast) and check50 still works for me, so you're probably fine for a while. – Melde Jan 6 '15 at 3:09
  • Exactly the same problem for me. Do not know what to do. – user2477 Jan 6 '15 at 7:20
3

I have just installed guest addition:

sudo apt-get install virtualbox-guest-dkms

and after restart the update50 worked fine. Try it.

The problem with displaying IP not solved but you can check your IP with ifconfigcommand in the terminal.

| improve this answer | |
  • Well, well, well. That worked like a charm. No idea why that worked when I'd already installed the Virtualbox guest additions - part of which removes, then recompiles and reinstalls dkms modules... but it did. – memilanuk Jan 6 '15 at 19:27
  • FWIW, it appears that you need both the guest additions installed, and the package mentioned above, in that order. Tried it the other way and it still hung up. Part of the package install will ask you where you want to install GRUB (boot loader); select /dev/sda (not /dev/sda1) – memilanuk Jan 6 '15 at 19:56
  • @memilanuk I think I canceled the step with GRUB - I was afraid to break something in the appliance itself. So, it still works. – user2477 Jan 7 '15 at 8:51
  • Your solution worked for me too on VMWare 11. Thank you so much! – user3115 Jan 31 '15 at 11:17
  • Changing the ip50 script to check eth0 works as well. – Quinten van der Werf Feb 16 '15 at 13:35
1

I had the same issue (installed from ISO on Hyper-V). I found that ip50 only checks for an address on eth1. Personally I only had eth0 active. I just updated the ip50 script to check eth0 instead and the IP address shows up fine now. Internet and appliance updates were working fine before and after.

To update the ip50 script, open a terminal window and run

sudo nano /usr/bin/ip50

Look for the line that reads:

declare inet=$(ip -f inet addr show eth1 2> /dev/null | grep inet)

and change it to read

declare inet=$(ip -f inet addr show **eth0** 2> /dev/null | grep inet)

Then CTRL+O to save the file and CTRL+X to exit. The change should almost immediately reflect by updating your IP address in the bottom corner.

| improve this answer | |
  • I believe the ip50 script looks for the address on 'eth1' for a reason - later problem sets use a web server running on that network to be visible from the host machine. So your solution gets rid of one symptom but doesn't solve the underlying problem - the appliance should have had two network cards set up 'out of the box'. – memilanuk Feb 16 '15 at 22:51
  • Thanks Memilanuk, that's good to know. – Quinten van der Werf Feb 19 '15 at 22:44
  • The IP50 file is being overwritten by Update50 so then the problem comes back. – user6593 Mar 17 '15 at 9:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .