I cannot seem to log in to https://x.cs50.net/2014/psets/0/ to submit my pset. I submited the link of the project in Scratch's library in CS50x 2015's studio but when I try to log in to edX, it says "Email or password is incorrect." I am sure there isn't a mistake. Why can't I log in?


The 2014 edX CS50x course finished on 31 December 2014. That link is for the 2014 course.

Be sure you are following the 2015 course. Here's the pset0 for 2015:


And the submit link shown there is:


  • I used the second link, however it leads to the edX course enrolment page even after login. – user3423 Jan 12 '15 at 23:48
  • Are you enrolled in the 2015 edition? Do you see an enroll button? – curiouskiwi Jan 12 '15 at 23:56
  • I'm enrolled in the class, I see the "Access Courseware" button. – user3423 Jan 13 '15 at 0:19
  • I have posted my project on CS50's scratch studio page, would that be sufficient? – user3423 Jan 13 '15 at 0:21
  • No, you definitely have to follow that link to submit your pset. I just tried it and it worked fine for me. It first brought up the edx login page and then, after entering my password again, it redirected to the pset0 submission form. Try signing out of edX completely from the course page and then clear your browser cache and then try that submit link again. – curiouskiwi Jan 13 '15 at 0:23

I had the same issue and I think the problem was that I was logging into EdX using my Google+ account. After I went into the EdX account settings and unlinked my Google account everything worked just fine.


In my case I did not need to unlink my Google profile but just went to my "account" page (accessible from the top right dropdown link) and reset my password from there.

After that I had access to the section.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .