I am making the mario.c program but when I try to compile it I run into the error stated in the title. I checked the code step by step and even tried making the adder program in the walkthroughs but I still get the same error.


If you haven't already, run update50. There's a bug in the built-in-terminal in gedit that this fixes. Alternatively, use the standalone Terminal app rather than the one in gedit, as that works fine.

  • Thanks, but by running update50 do you mean ./update50 or something else? I did that in edit and it was not found? I am new to this. Jan 31 '15 at 0:05
  • Open the Terminal app (from the CS50 Menu it's in Accessories>Terminal Emulator) or use the built-in terminal in gedit as you have been. At the prompt, type update50 and hit enter. It will take a few minutes to download the updates.
    – curiouskiwi
    Jan 31 '15 at 0:08
  • I did that. I got upgrade50: command not found Jan 31 '15 at 4:19
  • I have a MAC and am running Yosemite. Might that be the issue? Jan 31 '15 at 4:39
  • Did you install the appliance via these instructions? manual.cs50.net/appliance/2014 ? So you should have the appliance running as a virtual machine inside VMWare Fusion.
    – curiouskiwi
    Jan 31 '15 at 4:40

I run update50 on the terminal and the problem was resolved :D

  • This message would've been better suited as a comment to Curiouskiwi's answer. You can add comments to questions and answers by clicking the add a comment link displayed below each.
    – Calculemus
    Jan 8 '15 at 3:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .