6

I can't import the Appliance OVA file, appliance50-2014-vbox.ova, into VirtualBox. I keep getting the error message:

Result Code: VBOX_E_FILE_ERROR (0x80BB0004)

How do I fix this without switching to VMWare?

  • Don't know if this is going to help you but, there is also a bootable image. You can try to install it as a new virtual machine. here is the link mirror.cs50.net/appliance50/2014/releases/24/… – wallek876 Jan 8 '15 at 19:49
  • Are you using the latest version of VirtualBox? (4.3...) – curiouskiwi Jan 8 '15 at 20:31
  • yes I'm using the latest version – Lilly Jan 9 '15 at 15:53
  • @wallek876 How do I use that file? – someone Jan 9 '15 at 18:36
  • sorry i wrongly downloaded cs50-appliance-2.3.ovf file. And the answer was for ovf file. Downloading new appliance50-19-0-vmware.ova now. – Asher Malcom Jan 10 '15 at 23:09
3

If you received this message:

"Failed to import appliance C:/Users/Username/Downloads/appliance50-17/appliance50-17.ovf.

Error reading ":/Users/Username/Downloads/appliance50-17/appliance50-17.ovf": Disk item with instance ID 11 specifies invalid parent 4, line 117.

Result Code: VBOX_E_FILE_ERROR (0x80BB0004) Component: Appliance Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}"

There is a solution here:

https://forums.virtualbox.org/viewtopic.php?f=6&t=57992

2

I am not sure if this is still relevant, But I believe creating a new virtual machine is the solution.

  • New
  • Give a name to your VM
  • Type: Linux
  • Version: Ubuntu (64 bit) - But when I loaded the VM it says that appliance is of fedora distro [guess the version does not really matter]
  • Next
  • Select memory size
  • Choose "Use an existing virtual hard drive file"
  • Create
2

I'm currently using a windows 10. I have re-downloaded the virtual machine and it's still displaying this message. Can someone help me with this?

enter image description here

  • I am on linux and have the same error code. – Chopin Jun 25 at 14:45
0

guys download this file http://www.facebook.com/l.php?u=http%3A%2F%2Fmirror.cs50.net%2Fappliance50%2F2014%2Freleases%2F24%2Fappliance50-2014-vmware.ova&h=NAQFU3O8j

enter image description here Be sure you have the cs50 appliance with this icon...

If u already have this, then double click the downloaded file instead of installing file from Vmware workstation, After you double click the .ova file click the import button which will appear after. It will work for sure.

Thank you!!

  • i am also getting a similar problem during installation. this is the link to the problem i am facing. Kindly help if possible. cs50.stackexchange.com/questions/7753/… – karan kapoor Feb 13 '15 at 7:28
  • Are you getting the same icon which I have posted in?? – sandy Feb 19 '15 at 12:08
0

Navigate to the cs50-appliance.ovf file. Right click and open the file with a text editor (Sublime Text, Text Wrangler, etc.). For me it was on line 124 but the line number is referenced in the error I believe. change:
<rasd:Parent>4</rasd:Parent> to:
<rasd:Parent>3</rasd:Parent> Solved the problem for me.

Found this on
https://forums.virtualbox.org/viewtopic.php?f=6&t=57992

0

In my case it was corrupted oracle virtual box installation. I uninstalled latest setup. Installed an older setup. It works fine now.

0

In my case, same error appeared but on line number 53. Solution that worked for me : 1. extract the ova file contents using command : $ tar xvd appliancec50.ova 2. Edit the ovf file in vi..Go to line number 53. a. Change the tag 'ElementName' to 'Caption' b. Change the value of ResourceSubType from 'vmware_sata_ahci' to 'AHCI'. 3. Build the ova file again using command $ tar -cvf applicance50-2014_vmware.ova appliance50.ovf appliance50.mf appliance50-disk1.vmdk

  1. Import it in virtual box..

This mainly happens due to the different ways of handling ova files in vmware and virtual box

0

try this : 1. tar xvf myfile.ova -C /home/boshbosh/Desktop 2. then double click on ovf file and virtual-box automatically start and import your ovf done!

0

I had the same error message while trying to import an ova file (11Gb). I had previously imported that file many times without issues. So, what changed this time was the location of the imported file. I created another partition where I am going to store new vms, vmdk, etc. So, to fix this issue I used winrar to extract the ova, then copied it to the desired location. Imported vm is functional. Thanks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .