I can't import the Appliance OVA file, appliance50-2014-vbox.ova, into VirtualBox. I keep getting the error message:

Result Code: VBOX_E_FILE_ERROR (0x80BB0004)

How do I fix this without switching to VMWare?

  • Don't know if this is going to help you but, there is also a bootable image. You can try to install it as a new virtual machine. here is the link mirror.cs50.net/appliance50/2014/releases/24/…
    – wallek876
    Commented Jan 8, 2015 at 19:49
  • Are you using the latest version of VirtualBox? (4.3...)
    – curiouskiwi
    Commented Jan 8, 2015 at 20:31
  • yes I'm using the latest version
    – Cardamom
    Commented Jan 9, 2015 at 15:53
  • @wallek876 How do I use that file?
    – someone
    Commented Jan 9, 2015 at 18:36
  • sorry i wrongly downloaded cs50-appliance-2.3.ovf file. And the answer was for ovf file. Downloading new appliance50-19-0-vmware.ova now. Commented Jan 10, 2015 at 23:09

12 Answers 12


I am not sure if this is still relevant, But I believe creating a new virtual machine is the solution.

  • New
  • Give a name to your VM
  • Type: Linux
  • Version: Ubuntu (64 bit) - But when I loaded the VM it says that appliance is of fedora distro [guess the version does not really matter]
  • Next
  • Select memory size
  • Choose "Use an existing virtual hard drive file"
  • Create

If you received this message:

"Failed to import appliance C:/Users/Username/Downloads/appliance50-17/appliance50-17.ovf.

Error reading ":/Users/Username/Downloads/appliance50-17/appliance50-17.ovf": Disk item with instance ID 11 specifies invalid parent 4, line 117.

Result Code: VBOX_E_FILE_ERROR (0x80BB0004) Component: Appliance Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}"

There is a solution here:



I'm currently using a windows 10. I have re-downloaded the virtual machine and it's still displaying this message. Can someone help me with this?

enter image description here

  • I am on linux and have the same error code.
    – Chopin
    Commented Jun 25, 2019 at 14:45
  • i have the same issue i am using windows 10
    – shah nawaz
    Commented Aug 21, 2019 at 10:22
  • your post is not an answer Commented Oct 26, 2020 at 15:44

For me, the only that worked was right clicking the .ova file and opening with VirtualBox. Not sure why doing an import did not work, I am not a VB expert by any means.

  • this worked for me!
    – zentrunix
    Commented Sep 5, 2022 at 20:06

guys download this file http://www.facebook.com/l.php?u=http%3A%2F%2Fmirror.cs50.net%2Fappliance50%2F2014%2Freleases%2F24%2Fappliance50-2014-vmware.ova&h=NAQFU3O8j

enter image description here Be sure you have the cs50 appliance with this icon...

If u already have this, then double click the downloaded file instead of installing file from Vmware workstation, After you double click the .ova file click the import button which will appear after. It will work for sure.

Thank you!!

  • i am also getting a similar problem during installation. this is the link to the problem i am facing. Kindly help if possible. cs50.stackexchange.com/questions/7753/… Commented Feb 13, 2015 at 7:28
  • Are you getting the same icon which I have posted in??
    – sandy
    Commented Feb 19, 2015 at 12:08

Navigate to the cs50-appliance.ovf file. Right click and open the file with a text editor (Sublime Text, Text Wrangler, etc.). For me it was on line 124 but the line number is referenced in the error I believe. change:
<rasd:Parent>4</rasd:Parent> to:
<rasd:Parent>3</rasd:Parent> Solved the problem for me.

Found this on


In my case it was corrupted oracle virtual box installation. I uninstalled latest setup. Installed an older setup. It works fine now.


In my case, same error appeared but on line number 53. Solution that worked for me : 1. extract the ova file contents using command : $ tar xvd appliancec50.ova 2. Edit the ovf file in vi..Go to line number 53. a. Change the tag 'ElementName' to 'Caption' b. Change the value of ResourceSubType from 'vmware_sata_ahci' to 'AHCI'. 3. Build the ova file again using command $ tar -cvf applicance50-2014_vmware.ova appliance50.ovf appliance50.mf appliance50-disk1.vmdk

  1. Import it in virtual box..

This mainly happens due to the different ways of handling ova files in vmware and virtual box


try this : 1. tar xvf myfile.ova -C /home/boshbosh/Desktop 2. then double click on ovf file and virtual-box automatically start and import your ovf done!


I had the same error message while trying to import an ova file (11Gb). I had previously imported that file many times without issues. So, what changed this time was the location of the imported file. I created another partition where I am going to store new vms, vmdk, etc. So, to fix this issue I used winrar to extract the ova, then copied it to the desired location. Imported vm is functional. Thanks.


This is an Operating system error in your laptop, you probably trying to install in C: drive which has less space, Try to install another drive E:\ which should have good space.

I faced this same issue but got fixed when i installed in another drive.


Basically the OVA file (OVA2 it was in my case) is just a tar file (ref https://blogs.vmware.com/vapp/2009/08/inside-the-ovf-package.html) which contains the VMDK file and the ovf file (which is an XML containing description of the VM) and a checksum file. So if one renames the .ova to a .tar and extracts the VMDK file we are there (checksum can help verify integrity). Create a new virtual machine using this VMDK (in Oracle VirtualBox - Create New Virtual Machine --> when it comes to Hard Disk option, select "Use an existing virtual hard disk file") & select the VMDK you got by extracting the tar file and you should be done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .