0

i downloaded updated version of VMplayer from the recommended source mentioned by CS50 but after installing the VMplayer and importing the CS50 appliance-2014, there was this error SHA1 digest of file appliance50-2014-vmware-disk1.vmdk does not match manifest. How to fix this error.

0
0

Be sure you have the cs50 appliance with this icon:

You must download the appliance OVA.

If you already have this, then double click the downloaded file instead of installing file from VMWare workstation. After you double click the .ova file click the import button which will appear after. It will work for sure.

5
  • problem not solved, still facing that error. i did what you said to do. Jan 11 '15 at 15:46
  • I can help you through team viewer if you wish..
    – sandy
    Jan 11 '15 at 19:07
  • yup pls help me out. Jan 13 '15 at 10:07
  • contact me in facebook sandy.cg7@hotmail.com
    – sandy
    Jan 13 '15 at 10:09
  • Same error ... but when i download the cs50 appliance . ova is not written at the end .. can you help me out. Although when i download virtual box its written.
    – user8152
    Aug 14 '15 at 11:15
0

this is kind of difficult question, but doable. It seems that the .ova is incompatible with virtualbox. So, the easy solution is to download VMware.

If you insist in using virtualbox as i did, you just have to extract the .ova file and import the .vmdk inside it, that is the actual disk image. It seems that the .ova files are just compressed files, here are the steps to convert it correctly, what i did:

  1. untar the .ova file

tar -xvf appliance50_2014_releases_26_appliance50-2014-vmware.ova

---optional steps you can ignore them, check integrity of the .vmdk file, this was necesary to me, first time i uncompressed it i ended up with a corrupted file.-------

1.1 Check integrity

cat appliance50.mf output: SHA1(appliance50-disk1.vmdk)= d0ce6c5c239aca3d2b8df2a2e4af4ce114264f7a

sha1sum appliance50-disk1.vmdk output: d0ce6c5c239aca3d2b8df2a2e4af4ce114264f7a

If it is not the same, appliance is corrupted.

------ end optional steps.

2.Convert vmdk to virtualbox.

sudo VBoxManage clonehd --format VDI appliance50-disk1.vmdk cs50.vdi

Due to permissions i had to add sudo, this is not necessary in windows.

  1. After that you just create a new Virtual machine in vbox using the .vdi disk resulting these operations. Enter virtualbox, Click New, select linux as OS, select Ubuntu 32 bit, give it a decent amount of memory. Then follow the wizard, when it prompts to choose a hard disk, select the new .vdi image.

  2. Boot the machine

  3. Enjoy

It seems that you're running windows so i maybe you can use 7zip to untar the .ova file but i don't know if it will work, i don't use windows. Also it seems that you can use the .vmdk file directly, but it is better to convert it.

If someone has an easier way please post it.

See this posts for further reference:

https://opentox.github.io/installation/2012/08/02/converting-ova-images-to-kvm/

http://techglimpse.com/vmware-vmdk-to-virtual-box-vdi-vboxmanage/

-3

enter image description here

I am facing this Problem while importing CS50, please help

1
  • This does not answer the question, its another problem.
    – sinister
    Jan 11 '15 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .