1

I'm disabled and use an on-screen keyboard to type and I'm having a problem with VMWare. VMware won't accept input from my primary OSK (SofType) or from the default Windows 8 on-screen keyboard - is there a fix?

  • 1
    Have you tried the VM Ware Enhanced Virtual Keyboard? – Calculemus Jan 13 '15 at 1:11
  • Thanks for the suggestion but it didn't work. – Bob Bortolin Jan 13 '15 at 3:00
  • It's probably worth contacting VMware directly if Calculemus' suggestion didn't work – lethaljd Jan 13 '15 at 3:10
  • I just posted a question on their website - hopefully I'll hear soon. – Bob Bortolin Jan 13 '15 at 3:52
  • 2
    This is the answer I got on the VMware forum: "Actually there is no fix. On-screen keyboard from the host cannot pass through inside the VM. But you can use On-screen keyboard inside the guest OS" - any idea how I can do that? – Bob Bortolin Jan 13 '15 at 20:31
1

I don't have access to appliance 2014, but since it's Ubuntu-based, you should have an application called Onboard under the applications. If you don't, you may install it by executing

sudo apt-get install onboard

in the terminal (the password is crimson, if you are asked to enter one).

NOTE: you may copy and paste the previous line since you don't have keyboard in the appliance. You may refer to this for additional information about copying from your host machine and pasting into your guest machine.

| improve this answer | |
  • Thanks Kareem, I got Onboard installed and it shows up on the Menu, but clicking on it doesn't do anything - is there something else I have to do bring up the OSK? – Bob Bortolin Jan 15 '15 at 1:01
  • @BobBortolin what happens when you execute onboard in the terminal? – Kareem Jan 15 '15 at 6:01
  • Sorry for the delay. After I click the Onboard menu entry nothing happens: no error, no splash screen, etc. – Bob Bortolin Jan 29 '15 at 4:05
  • @BobBortolin, I was actually asking about executing onboard on the terminal! – Kareem Jan 29 '15 at 10:50
  • Sorry for the misunderstanding. Here's the output:jharvard@appliance (~): onboard 2015-01-29 15:38:47,586:WARNING:Config: mousetweaks GSettings schema not found, mousetweaks integration disabled. Traceback (most recent call last): File "/usr/bin/onboard", line 16, in <module> ob = Onboard() File "/usr/lib/python3/dist-packages/Onboard/OnboardGtk.py", line 111, in init self.init()...There's more but it's too long for this comment box. – Bob Bortolin Jan 29 '15 at 20:41
0

I actually found a solution: If I connect my Host System with TeamViewer to the CS50 Appliance, then my OSK works fine as long as I interact only with the TeamViewer representation of the CS50 desktop. I hope that makes sense! :)

| improve this answer | |
0

If you want to use Host On-Screen keyboard with VMware workstation you have to do some setting for that follow step below :

  1. Go to workstation menu.
  2. Click on edit button.
  3. Click on Preference.
  4. Click on Input.
  5. Check mark on "Grab keyboard and mouse input on key press".
  6. Click on ok button.

Now it done..

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .