I am having some issues with the 2014 Appliance on VirtualBox.

I have imported it correctly, however, I have no IP address in the taskbar (though I have internet) so I feel like my network devices aren't setup correctly (only running NAT).

Also, I run into a GRUB configuration issue when I run update50, and there is an issue with pma control user configuration when using phpMyAdmin for pset8.

Does anyone have any advice on how to fix these issues?

EDIT When I run update50 it updates the GRUB configuration and I encouter GRUB configuration messages. This also occurs when I run sudo apt-get update.

Also, for the phpMyAdmin issue, the error is #1146 - Table phpmyadmin.pma_table_uiprefs doesn't exist but I am able to upload the the SQL command required for pset8.

  • For your first problem, there is already an solution posted, search for "appliance network adapter", that worked 4 me, your second problem: GRUB is a linux bootloader, isn't it? don't know how that interfere, with update50... your 3rd problem is described way to vague (as is your 2nd) to provide any suggestions...
    – SebBr
    Jan 15, 2015 at 19:19
  • I have followed the advice from the other posts and I got the network adapters working and can access the internet, however, there is still not an IP. I dove into the script that displays the address and if I change eth1 to eth0 I can display the IP but it changes upon update. Also, I updated my post so hopefully it's a little more clear. Thanks!
    – user2137
    Jan 16, 2015 at 1:09

1 Answer 1


Here's the solution for no IP address in task bar. It worked for me!


You must log in to answer this question.