0

I downloaded the Ubuntu mirror from CS50 class link, set up Dropbox and attached it to the appliance. I followed the instructions to create a hello.txt file. I saved it and it read hello.txt (~/Dropbox/pset 1) - gedit, just like the instructions said it should. With the hello.txt file open, I then opened the command line and typed ls, which gave me a directory showing that Dropbox was there. I then then typed cd ~/Dropbox/pset 1 and according to the instructions I should get a prompt showing that I am inside ~/Dropbox/pset 1. Instead of that prompt, I get this,

-bash: cd: /home/jharvard/Dropbox/pset: No such file or directory jharvard@ubuntu (~):

I have searched the forums and I can't find a situation just like mine. However I have found somewhat similar scenarios and I have tried mkdir from the terminal to try and create the pset 1 file. I have also tried to update gedit, I re-read the instructions over and over. I have tried pset1 insead of pset 1. I can't figure why it's not connecting.

1

I decided to delete my hello.txt and pset 1 files and start from scratch. I named the latter pset1 and now everything looks great! Last time I tried to rename pset 1 to pset1, I just did a backspace with the file open. Thank you for pointing in the right direction.

0

The terminal doesn't understand that your directory name has a space in it. The problem set actually suggests naming the directory /pset1/ without a space in between to avoid this issue.

That said, if you don't want to change your directory name, in order to get the shell to understand what you mean when, you have to insert a \ before the space, as follows:

cd ~/Dropbox/pset\ 1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .