I am working on pset7 and have loaded pset7.sql into phpMyAdmin, but whenever I try and click on 'users' in the left hand column I get an error message which includes "#1146 - Table 'phpmyadmin.pma_table_uiprefs' doesn't exist. I have included a screenshot below: enter image description here

I can't workout what the issue is so any help is much appreciated! Thanks.

  • I have the same problem. Also, it should be mentioned that immediately after logging in as jharvard I encountered another error "Connection for controluser as defined in your configuration failed." which i think is related to the one stated by coderUK. And also as i noticed we both have the problem discussed in this topic cs50.stackexchange.com/questions/7338/….
    – user4726
    Commented Jan 18, 2015 at 14:11
  • Yes, I too am followed around in phpMyAdmin with "Connection for controluser as defined in your configuration failed". This has ground me to a halt with my progress so any help would be fantastic! Commented Jan 19, 2015 at 8:30
  • I am getting an ERROR 1045 Access denied for user ""root""@'localhost'(using | |password: YES)
    – Kohl
    Commented Feb 23, 2015 at 3:39
  • I changed my email address attached to my edx account, and after that my grades dissipated. Rob fixed this for me, but now I have the problem listed in this thread (error message " Connection for controluser as defined in your configuration failed.)" in phpmyadmin. I am also getting an error message in IDE, "[Tue Oct 04 18:04:31.825340 2016] [alias:warn] [pid 8374] AH00671: The Alias directive in /etc/apache2/sites-enabled/phpmyadmin.conf at line 3 will probably never match because it overlaps an earlier Alias." I have tried the steps for sudo dpkg-reconfigure phpmyadmin several times, logging Commented Oct 4, 2016 at 18:15

1 Answer 1


The "Connection for controluser as defined in your configuration failed" problem can be eliminated by refreshing the configuration of the the phpmyadmin package.

Open a terminal window by clicking the terminal icon to the right of the colorful Chrome icon near the lower left corner of the appliance screen. In that terminal, run

sudo dpkg-reconfigure phpmyadmin

In the resulting configuration dialog, you move among the field on each screen by pressing Tab or Shift+Tab. On some screens, you can just Tab to highlight your answer (such as Yes, or Ok) and then press Enter/return to move to the next screen. On other screens, you will need to select and option or type in text before tabbing to the Ok "button" and pressing Enter/return.

Here are suggested answers:

  • Reinstall database for phpmyadmin? Yes
  • Connection method for MySQL database of phpmyadmin: Leave "unix socket" selected, then Ok
  • Name of the database's administrative user: Leave "root", then Ok
  • Password of the database's adminstrative user: Type crimson, then Ok
  • MySQL username for phpmyadmin: Substitute pma for phpmyadmin, then Ok
  • MySQL database name for phpmyadmin: Leave "phpmyadmin", then Ok
  • Web server to reconfigure automatically: Leave "apache2" checked, then Ok

The dialog will close and the web server will be restarted so that the changes take effect.

  • I had the same problem, and this answer resolved it. Thank you!
    – pokerbeing
    Commented Jan 31, 2015 at 0:42
  • After following these instructions, I receive this error: i.imgur.com/VBsi3Qs.png
    – edgar_is
    Commented Jan 31, 2015 at 21:24
  • I tried this solution, but now I have an error where no matter what I type in when I go to http://pset7/phpmyadmin, it doesn't authenticate. It just keeps prompting me for a username/password. I've tried many usernames including "jharvard" and "pma" but even though they might match the admin name I typed in via your instructions, they do not work. Any idea what's going on?
    – Michael F
    Commented Jan 31, 2015 at 23:06
  • @MichaelF: That's an independent bug in phpMyAdmin. It's there whether or not the phpmyadmin package is reconfigured as described above. The workaround is to cancel or close the authentication dialog, then return to http://pset7/phpmyadmin/ and log in again. Commented Feb 1, 2015 at 3:19
  • 1
    @EdgarSanchez: Normally, the MySQL password of the administrative MySQL user root is crimson. What happens when you run the following one-line command in a terminal in your appliance? echo exit | mysql -u root -pcrimson It should just return to the command prompt without printing anything. Does it? Commented Feb 1, 2015 at 4:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .