0

I recently started using VirtualBox and the updated version of the appliance. Any time I click on the gedit shortcut, or when I try to launch edit from the terminal, it crashes before starting up and I get an error. In the terminal, it's a seg fault, clicking the shortcut on the desktop gives a prettier error and sends a crash log to linux.

I have tried running update50 multiple times. It updated the appliance the first time but all subsequent tries have shown that the appliance is now up to date. I have also tried restarting the appliance multiple times.

Thoughts?

enter image description here

3

https://askubuntu.com/questions/528192/gedit-closes-unexpectedly-with-segmentation-fault-core-dumped

Someone there says that this may be a bug, but there are a couple of things you can try.

1) Try moving gedit's config directory so that it can generate a new one. Enter the following command at the terminal and then try to start gedit again.

cd ~/.config && mv ./gedit ./gedit.old

2) Assuming the jharvard user has adequate permissions (unfortunately I have no way to check if it does at the moment, I am not using the appliance), remove and then reinstall gedit. You will be prompted for jharvard's password.

sudo apt-get purge gedit && sudo apt-get install gedit

If niether of those work, there are other text editors you can use. 'Vim' is an excellant editor that is ran from the terminal, but has a bit of a learning curve. 'Kate' is another, and it, like gedit, has a gui. You can also try reinstalling the appliance. Beyond that, I am afraid that I don't have many more suggestions.

3
  • Thank you. I will give this a try later tonight.
    – lethaljd
    Jan 21 '15 at 12:48
  • Option 1 was a no go. Option 2 worked like a charm, despite some strange command line messages about "wrong magic bytes". Thank you!
    – lethaljd
    Jan 22 '15 at 0:06
  • I had the same trouble. The option 2 did the wonder on my VM as well. Thank you! Yoshi Watt
    – Yoshi Watt
    Feb 11 '15 at 5:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .