I recently downloaded VirtualBox and imported the CS50x Appliance. I am unable to open gedit and receive the below error message, included as a screen shot. If someone can assist me on what I should do in order to resolve this I would be much obliged.

Error Message when attempting to open Gedit

  • possible duplicate of Gedit is not working on CS50 Appliance
    – kzidane
    Jan 23, 2015 at 9:30
  • Not a duplicate, but we need more information. Did you try restarting the computer, as suggested in the error dialog? Can you copy/paste the text from the error box into your question, so we can see the whole thing (it has a scroll bar)?
    – Air
    Jan 26, 2015 at 17:02
  • Yes, but what worked to solve the problem was curiouskiwi's advice. I only have the enclosed screen shot to describe the error.
    – jswein
    Jan 27, 2015 at 1:53
  • You can also use another editor.
    – user2477
    Jan 28, 2015 at 12:37

1 Answer 1


The VirtualBox version of the appliance currently has an issue with the gedit install. Staff are aware of it and are working on a fix.

In the meantime, run this:

sudo apt-get update
sudo apt-get install --reinstall gedit 

That should get it up and running again.

  • This fix worked for VirtualBox running on a Windows 7 PC.
    – pokerbeing
    Jan 31, 2015 at 13:21
  • Reinstall fixed the problem on my Ubuntu 14.10 desktop running Virtualbox as well.
    – user4999
    Feb 4, 2015 at 21:28
  • This code fixed the same problem for me as well. Feb 7, 2015 at 3:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .