I click on the provided link (http://cs50.edx.org/vmware) and wind up at this page (https://x.cs50.net/auth/) which is blank. I have enabled cookies but this hasn't changed the redirect. Can't think of what else to try. Suggestions would be much appreciated!

  • I tested using firefox and chrome on windows 7, and for me is working on both. What browser are you using? – wallek876 Jan 28 '15 at 19:18
  • I'm using chrome on Windows 8.1. – Shawn Barnes Jan 28 '15 at 19:36
  • That link is blank for me too - tried on Firefox and IE on Windows 8.1 – user6303 Feb 23 '15 at 2:27
  • Has anyone solved this?? I'm having the same problem! – user7335 Jun 8 '15 at 20:51

The link redirects you so as to log-in through openid.edx.org and then automatically sends your credentials to https://harvard-cs50x.onthehub.com, where you already get signed-in.

  • Downvoter, please state the reason for your action. Thank You. – sinister Feb 24 '15 at 11:08

It is strange, this is the direct link to the WMware software center for cs50x:


Once there click in Sign In on the column Single Sign-On. This should redirect you to the edx open id login page, log in with your edx credentials and then you should be automatically logged in the WMware software center for cs50x.


Probably solved now for most but only way I could get to download was via Safari - worked fine here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .