7

I have researched for 3 days and can't find an answer.

My Gedit is not showing the bottom panel terminal, and the bottom panel option in "view" is grayed out. I went to Edit > Preferences >Plugins, and I could not find the terminal plugin. I have ran the following without results:

sudo apt-get update

sudo apt-get install gedit-plugins

purged gedit and reinstalled it

While installing and uninstalling Gedit I have also gotten back some curious messages:

/var/cache/apt/archives/gedit-plugins_3.10.1-lubuntu2_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

and also:

/sbin/ldconfig.real: /usr/lib/i386-linux-gnu/libzeitgeist-2.0.so.0.0.0 is not an ELF file – it has the wrong magic bytes at the start

When I tried the following: sudo apt-get update (followed by) sudo apt-get install --reinstall gedit, It showed me: E: internal error, no file name for gedit:i386

I haven't been able to continue the class in almost a week! Please help!

P.S. Note that I use vbox, since vmware requires mac os 10.8 or later, and i have mac os 10.6.

15

Another student, in whose appliance the gedit-plugins package was missing, found that the following two commands solved the problem:

sudo apt-get install -o Dpkg::Options::="--force-overwrite" gedit-plugins
sudo apt-get install -o Dpkg::Options::="--force-overwrite" --reinstall appliance50

One issue is that both gedit-plugins and appliance50 install a file called terminal.py at the same location. The first command above forces the overwriting of that file, which allows gedit-plugins to be installed, but with the wrong terminal.py file. The second command allows the file to be overwritten again with the preferred version.

| improve this answer | |
  • You sir deserve a free chocolate. This worked for me beautifully and now I have the terminal in the bottom section of gedit! – user4995 Feb 5 '15 at 5:42
  • I ended up trying this video youtube.com/watch?v=kcoRaJLMX-U and it worked!! (even though it says for windows and I have MAc OS, I just had to adjust in a couple of instances, otherwise it worked well. Didnt get to try the one above, but sure will if I get any more trouble. Thanks a lot guys, stackexchange is great :) – Andresm11 Feb 7 '15 at 18:09
  • Thank you. This solution worked a charm for me - July/9/2015 – user7656 Jul 9 '15 at 20:12
  • Thanks! While doing C$50 Finance, i somehow lost permission to the terminal plugin--I could see it in the gedit preference but could not enable it. This allowed me to reinstall gedit with the right permissions. All seems well now. – Steven Graboski Aug 21 '15 at 23:15
  • Thank you so much for this great answer. Worked perfectly! – user9677 Sep 23 '15 at 1:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .