0

I'm trying to find a spanish layout to my Apple spanish keyboard, but there's a problem with the "<>" and the "ºª\" keys. Inside the appliance those keys are not working right, the "<>" key, inputs "ºª\" and viceversa. How can I fix it?

Bonus: Appliance does not have 1920X1080 resolution. :( I can't run it full screen, that's so bad, I had a better experience working in Windows :(:(:(

0

Took me a while to find out the answer, but here we go:

  1. Go to Menu > Settings Manager > Keyboard
  2. Go to the Layout tab
  3. Unclick "Use system defaults"
  4. Leave all 3 options (Keyboard model, Change layout option & Compose key) in blank (-)
  5. Click "Add" and look for the "Spanish Spanish Macintosh" Keyboard layout
  6. Erase the default English one
  7. Close the window (you're almost there)

Note: Now you'll have your keyboard working ;) But oh! Still 2 keys are swapped :S (the < > and the º ª ), which is way better than what we had before, but take the steps below to fix it and have it all up and running ;)

  1. Now, go to the terminal
  2. write this line and hit enter:

xmodmap -e 'keycode 94=masculine ordfeminine backslash brokenbar backslash brokenbar' -e 'keycode 49=less greater'

  1. Voilà! All done ;) Fully functional Spanish Mac keyboard on CS50 appliance!

Hope it helped!

L

Sources:

For the keyboard settings: https://manual.cs50.net/appliance/19/#how_to_change_keyboard_layout

For the code for the swapped keys (Look for post Pablo Ledesma (venraiker) wrote on 2009-04-27:): https://bugs.launchpad.net/ubuntu/+source/linux/+bug/214786

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .