OK, I've hit my first snag while taking CS50x. I manged to get Appliance50 2014 running on VirtualBox on my little Acer Aspire One. However, it is unusably slow. Hardware Virtualization is not a option. I'm running Lubuntu 14.1. I've downloaded the ISO file but I am a little lost as to how to get it installed on my empty partition /dev/sda3. I have found several tutorials online for booting the ISO from hard disk, or installing other distros -- just not certain which method will work best for Appliance50 (still fairly new to Linux).

I would prefer to go the full install route, instead of installing the individual libraries along with clang, and all the rest (as it appears others have run into some issues with that mnethod). I'd rather just boot into the Appliance and use it (more or less) as it's intended to be used as described in the course, but not in a virtual machine.

Thanks in advance for any/all help! Much appreciated.

  • I never tried that before, but appliance 2014 is Ubuntu-based. You should find the steps here or here useful for creating your bootable disk. And the steps here useful for installing the operating system.
    – kzidane
    Feb 17, 2015 at 9:11
  • Sorry, I should have mentioned in my post that I tried the above suggested menthod. Unfortunately, the startup disk creator doesn't work with Appliance50 ISO. I always get the error "An uncaught exception was raised: unorderable types: NoneType() <= str()". I get the same results on both my Linux boxes (both running Lubuntu). I thought perhaps there might be a way to do it through command line, similar to creating a startup disk for Porteus (which I never did get to work, but perhaps that's more my fault than anything else)?
    – Karl
    Feb 17, 2015 at 14:25
  • Hi I have a netbook too, I'm running the appliance in my desktop which has decent amount of resources, but I would like to get movility, as you, I tried to install via VirtualBox in my netbook with ArchLinux but like you is extremelly slow.. If you like we can experiment, I have experience installing many kind of linux distros
    – Daniel N.
    Feb 18, 2015 at 0:33
  • Hey @danfly09. I'm open to any ideas you might have. I'm not familiar with installing Linux via command line, so of the tutorials online that I've seen for various distros I'm not sure which one might apply to Appliance50. But I'm willing to try.
    – Karl
    Feb 18, 2015 at 1:35
  • let me download the appliance ISO, it will take me a while, my bandwidth is sad u.u I'm not sure until I proceed to install it, but this appliance is Ubuntu based, so I think it would be easy like Ubuntu, with graphical interface and easy stuff
    – Daniel N.
    Feb 18, 2015 at 1:51

1 Answer 1

  1. Download the last appliance50-2014.iso release at http://mirror.cs50.net/appliance50/2014/releases/

  2. Download a program called Rufus (for Windows) to make an usb_stick booteable. For another OS good luck =/

  3. Boot from the usb and select install the appliance50

  4. Is highly recommendable prepare the partition where you'll gonna install the appliance before all this process. If you did so, when ask for delete all your data and install the appliance, of course you will say no, you will select more options.

  5. Inside there, partitions are named /dev/sdXX (/dev/sda1, /dev/sda2) (same letter means same disk, numbers are the partitions) select what you have prepared and click edit.

  6. Use as ext4, install the root directeroy ('/'), and check format disk.

  7. Save changes, and continue, after that, rest of the process is easy, just make sure you are plugged to internet, installation process needs it.

  8. Once installed, in a terminal, execute update50 twice.

PD: Is probably that because I have another Linux distribution installed and I already have a swap partition the installation process don't alert me about this, but if the process prompt to you the alert you have no swap partition, you can ignore them, this is for computers with low Ram, less than 1GB, and swap behave like more Ram

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .