I had zero programming knowledge before taking CS50 and worked my way up to pset3.

While I was working on it today, I encountered some huge difficulties. Suddendly, I wasn't able to work on my files anymore due to "read-only file system". I've tried everything I could think of, but neither restarting everything nor deinstalling and reinstalling it worked.

I worked my way through google, but I was not able to understand the directions a stumbled upon.

Does anyone have a suggestion to solve this? One that I can actually implement? Keep in mind that I am not a computer geek yet :)

Thank's a lot!

  • As long as you saved all your pset work in the Dropbox folder, and you remember your Dropbox credentials, you should be ok (all things considered). If you have to delete the virtual machine (appliance), re-download it, and update it, you can reconnect to your Dropbox instance and be up & running again in short time. Feb 18, 2015 at 23:48
  • Thank you, that's what I did in the end. Although the first time it didn't change anything. Now it seems to be working. Fingers crossed.
    – Kubiti
    Feb 19, 2015 at 17:01


You must log in to answer this question.

Browse other questions tagged .