In pset7 I've created the database successfully in phpmyadmin but when I click on "users" to open the table I get an error message: "#1146 - Table 'phpmyadmin.pma_table_uiprefs' doesn't exist.
I've found some solutions but they all involve modifying settings I'm not confortable with.
I've tried update50 but the problem is still there.
What should I do?

  • This is a bug in PMA. You need to create manually another user and a couple of databases. Google this error - there is a solution for this.
    – user2477
    Commented Feb 20, 2015 at 10:04
  • 1
    Alternatively, you can use the MySQL command line interface. Open your Linux Terminal and type mysql -u <your mysql username> -p. You will be prompted for a password. Enter your mysql password and you are in. Just type your queries as normally.
    – user2477
    Commented Feb 20, 2015 at 10:07
  • Before posting I found two solutions online, one with sudo dkpg-reconfigure phpmyadmin but this one asks for settings I have no clue about and another more manual one but I do not understand what the first two steps are: 1 On the shell: locate create_tables.sql. 2 import /usr/share/doc/phpmyadmin/example/create_tables.sql.gz using phpMyAdmin. 3 open /etc/phpmyadmin/config.inc.php and edit lines 81-92: change pma_bookmark to pma__bookmark and so on.
    – Claire
    Commented Feb 20, 2015 at 10:58
  • Try sudo dpkg-reconfigure phpmyadmin in your terminal and answer yes for a request to re-install PMA. Then restart apache with sudo service apache2 restart.
    – user2477
    Commented Feb 20, 2015 at 11:07
  • shell, bash, terminal etc. are alternative names for your command line interface. So, "On the shell: locate create_tables.sql" means: run command locate create_tables.sql in your terminal window.
    – user2477
    Commented Feb 20, 2015 at 11:11

2 Answers 2


Just had the same problem. The comments give clues and partial answers, but not complete details. curiouskiwi provided a complete solution:

1) run sudo dpkg-reconfigure phpmyadmin in a terminal window.
IMPORTANT: ACCEPT ALL DEFAULTS GIVEN. Changing defaults may not result in a complete fix.

2) Next, run sudo service apache2 restart

This is described at https://cs50x.slack.com/files/curiouskiwi/F04CWT6RN/Problem_Set_7_PHPMYADMIN_problems

  • Unfortunately does not work Commented Dec 15, 2015 at 22:04

I was also having this problem. The fixes: sudo dpkg-reconfigure -f noninteractive phpmyadmin and sudo service apache2 restart were not working. I duckedduckedgo a bit, tried a few suggestions and the one that solved it was this one here:

Modifiy the configuration file config.inc.php.


$cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';


$cfg['Servers'][$i]['pma__table_uiprefs'] = ‘pma__table_uiprefs’;
  • How to you find and edit the config.inc.php file?
    – buitri84
    Commented Nov 16, 2015 at 9:41
  • Just type sudo gedit /etc/phpmyadmin/config.inc.php at a terminal window. Save and you should be good to go :)
    – José
    Commented Nov 16, 2015 at 13:12
  • Unfortunately does not work Commented Dec 15, 2015 at 22:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .