Snag #2: so @Danfly09 helped me to get the Appliance installed alongside my Lubuntu install, on a separate partition. Everything appears to work OK, except that I keep getting errors when updating. It seems my apache2 has unmet dependencies. Specifically apache2-bin and apache2-data. It's my understanding that this will become a major problem in later problem sets. But for me, right now, it's a major problem because I can't get anything to install properly, such as a network manager so I can get my wifi working properly while booted into the Appliance. Once again, being new to Linux, I tried several potential solutions bit none of them worked -- not surprising really since none of the solutions were geared specifically for the Appliance. Either that, or my lack of mad Linux skills means I'm not understanding the problem, and therefore not understanding what the solution should be. Here's a few screenshots for info: Step 1: apt-get check Step 2: apt-get -f install Step 2: continued

I think I understand the problem -- but probably don't. Once again, thank you in advance for any and all help.

1 Answer 1


The obstacle appears to be that apache2_2.4.7-1ubuntu4.1_i386.deb can't be installed for fear of clobbering a file that appliance50 has previously overwritten. So try

sudo  apt-get -o Dpkg::Options::="--force-overwrite"  install  apache2
sudo  apt-get -o Dpkg::Options::="--force-overwrite"  install  --reinstall  appliance50

That should leave the shared file in the form that package appliance50 prefers.

  • It's alive!!!...er...I mean, it worked! But I've lost my network adapter. Originally when I set this up, I found a "fix" for my missing network adapter in which I ran sudo nano /usr/bin/ip50 and found the line containing eth1 2> /dev/null and changed it to eth0 (this was per a possible solution posted here cs50.stackexchange.com/questions/6166/problems-running-update50). With the forced re-install it's gone back to eth1. Do I need to change that again or is that not the real problem?
    – Karl
    Commented Feb 22, 2015 at 4:03
  • @Karl: Your change to ip50 isn't recovering your missing secondary adapter (eth1). It merely makes the address of the primary adapter (eth0) appear where that of eth1 would normally be on the appliance screen. With a VMware hypervisor, you don't need the secondary adapter. The primary (eth0) will serve all your needs. Run the command ifconfig eth0 and make note of the IP address following the symbol inet. Use that address as the IP address of the appliance whenever you need to access it from your host (physical) computer. Commented Feb 22, 2015 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .