1

spl_error

I followed the instructions in pset3 but received a fatal error shown below. It was stated that the spl is stored somewhere in the new version of appliance which I think I have. I tried replacing gwindow in quotation marks. didnt work. I also found whole "spl" folder online and placed in the same folder but didnt work either. I cant proceed any further in pset3. Any idea how to go about this?

thanks

1
  • please can you provide the link for the 2015 CS50 appliance, I'm also facing the same problem. Jun 5 '15 at 4:03
1

This is because you are trying to compile the 2015 version of breakout with the 2014 version of the appliance.

The best thing you can do is install the new appliance and then the files in src4m/ should compile with no problem. Also this way you will avoid possible problems in the problem sets that are different from the ones in 2014.

But if you want to compile this files anyway, you need to find the last year source files for the spl library, you can download it from the terminal by running this command:

wget http://cdn.cs50.net/2013/fall/lectures/5/m/src5m.zip

Then you can compile the files in this package or if you want to compile the ones you have you need to copy in the scr4m/ folder, not only the spl folder you need to copy also the spl.jar file, and overwrite the Makefile with the one in src5m/. and change your include statment to:

#include "gwindow.h"
12
  • Thanks for the answer but I am confused about the version of the Appliance. If you look closely at the picture above, it says "19.2" as the version of the appliance (3rd line from the bottom). Isnt this the most recent version of the appliance?
    – Stealth
    Mar 12 '15 at 16:07
  • @Stealth The appliance you are using is the old one based on fedora, and you can not update more than 19-2. But there is a new version based on ubuntu for this year course, to switch to this last version you need to install it from scratch you can not update. here in the manual is explained manual.cs50.net/appliance/2014/#how_to_update_appliance
    – wallek876
    Mar 12 '15 at 16:18
  • Thank you so much. I was just reading the website you referred above. You're right and I already started downloading the new version. Thanks again
    – Stealth
    Mar 12 '15 at 16:22
  • Thank you all for this. I was having the same issues. I checked my version number only to realize that it was 19-2. I guess I'm also on the old fedora version from 2013. Going to go update the appliance tonight.
    – Alex Wang
    May 23 '15 at 22:50
  • please can you provide the link for the 2015 CS50 appliance, I'm also facing the same problem. Jun 5 '15 at 4:03
0

Just to clarify this, both the new hypervisor (WMware Workstation 11 in this case when using 64-bit Windows) and ALSO the newer appliance needs to be downloaded as the 2014 version may not be updated beyond 19-2 using update50. The links to both of these are below. Thanks for the advice above though, I had the same problem on pset3 and eventually resolved it.

WMware Workstation 11

http://cs50.edx.org/vmware

CS50 Appliance (2015 Version for CS50x users)

http://mirror.cs50.net/appliance50/2015/releases/0/appliance50-2015-vmware.ova

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .