I have thoroughly followed the instructions step by step to execute hello.c . However, the message "no rule to make target hello" continues to show. Any help?

enter image description here

3 Answers 3


It appears that you file name has a leading space. You should probably rename it by executing

mv " hello.c" hello.c

then try making it with

make hello
  • I just did what you said and the problem has been solved. Thank you so much! Mar 14, 2015 at 20:05
  • @AticaFernandez you may accept the answer to mark your question as solved!
    – kzidane
    Mar 14, 2015 at 20:52

You haven't saved the file to the disk, see the * sign on the tab. Press Ctrl+S to save the file and then do make hello.

  • I just did what you said, but it did not avail. Mar 14, 2015 at 3:31
  • What's the error message?
    – sinister
    Mar 14, 2015 at 4:43
  • No rule to make target 'hello'. stop Mar 14, 2015 at 6:04

It happened with me too. Just make sure to change your directory to the one where your file is saved in the terminal window. It may be ~/Dropbox/pset1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .