0

When I open gedit from the toolbar down below I get this gedit and if I open it through using root I get the the one that's like the later one. I'm also getting the error which is shown in the terminal of the later pic. Please help me guys. enter image description here

enter image description here

2
  • Well the second is with a command line - do you not want that? Or do you want to be able to open it with the command line without using root?
    – Tim
    Mar 20 '15 at 15:40
  • I want to be able to open it without using root
    – Vivek Giri
    Mar 20 '15 at 18:34
1

The command "make" seems to be lacking some flags, try compiling it on your own with the "-lcs50" flag to link the library, i.e.

clang credit.c -o credit -lcs50

If you want "make" to behave like it should, you can export the C-flags to something like:

export CC=clang
export CXX=clang
export CFLAGS="-ggdb3 -std=c99 -Wall -Werror"
export LDLIBS="-lcs50 -lm"

Happy coding =)

Not the answer you're looking for? Browse other questions tagged .